Problems - LinuxMint; FT8; FLDIGI

Discussion in 'Computers, Hardware, and Operating Systems' started by G4TWW, Jan 15, 2019.

ad: L-HROutlet
ad: l-rl
ad: QSOToday-1
ad: Subscribe
ad: Left-2
ad: Left-3
ad: abrind-2
ad: L-MFJ
  1. G4TWW

    G4TWW Ham Member QRZ Page

    I am running LinuxMint to a FT817 via a ZLP Digimaster ProPlus. Using supplied USB lead from ZLP to computer; CAT lead to the 817; and audio in/out from 817 to computer mic/speaker sockets. Having great difficulty in getting FT8 or FLDIGI to operate. After some weeks now have FT8 receiving; but no rig control whatsoever! FLDIGI is even worse!!!
    Linux is OK for Drivers and finds the audio in/out ok.

    Everything works OK if I revert to Windows, but I would prefer to leave Windows for good.

    Clearly I have missed something, or am approaching from the wrong direction, or using the wrong rig-control set-up.
    Any advice/ ideas would be most welcome
    Mike G4TWW
     
  2. KF5FEI

    KF5FEI Ham Member QRZ Page

    Got your user in the dialout group? Serial port access requires this.
     
  3. G4TWW

    G4TWW Ham Member QRZ Page

    Hi
    Yes, sorted that. Your comment "Serial port access" is making me re-think the whole set-up, perhaps I should try a USB to Serial link?
    Thanks,
    Mike
     
  4. KF5FEI

    KF5FEI Ham Member QRZ Page

    Since the 817 uses 5-volt TTL serial, you cannot connect a standard PC (DB9 / DB25) serial port direct to the radio. You either need a level-shifter, or just use a USB-to-CAT converter.
     
  5. G4TWW

    G4TWW Ham Member QRZ Page

    Hi
    Thanks again. I am checking out what you say, but I am sure that connections via the Digimaster and not direct covers that. The Digimaster uses a USB 'B' out to a USB 'A' into the computer. I shall keep trying!
    Mike
     
  6. K8WDX

    K8WDX XML Subscriber QRZ Page

    In Fldigi, change port audio to pulse audio, first make sure pulse audio is installed, do this through the software center. then make you adjustments through pulse audio. See if the works for your receive.
     
  7. VK4JE

    VK4JE Ham Member QRZ Page


    Hi,
    I am wondering if you sorted this issue out, as I am in a similar boat
    I have a FT-847
    Using a Digimode-3-Yaesu
    All works fine on Win10

    I am using LinuxMint Cinnamon 20
    I have the Audio working fine it is a cat control that is my issue
    The setup gives me 3 choices:

    1) /dev/ttyUSB0
    2) /dev/ttyS0
    3) USB

    None of each do the trick

    Any pointer gratefully received

    Cheers
    Ron
    VK4JE
     

Share This Page