problem with WSJT-X ver 1.8

Discussion in 'Amateur Radio Software' started by KB6KAX, Oct 2, 2017.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: L-MFJ
ad: Left-2
ad: Left-3
ad: MessiPaoloni-1
ad: l-assoc
  1. KB6KAX

    KB6KAX Ham Member QRZ Page

    My new PC has an issue with the new WSJT-X Version 1.8 ,other programs on my PC work OK. I am running Windows 10 , when I download then try to open WSJT-X Ver 1.8 it crashes every time I start program. I have downloaded Ver 1.8 from Joe's site and SourceForge ... both do the same ... crash.
    I then tried to load Ver 1.7 but it would not load.
    I got Microsoft involved via their customer service chat , I mentioned to them I had a STALE LOCK FILE error too and they told me about software they have ( for FREE ) to locate files that a normal program delete did not remove.
    The program from Microsoft is called SYS INTERNEL PROCESS EXPLORER.
    I downloaded this software from Microsoft.
    MicroSoft suspected a file from Ver 1.8 was still on my PC ,sure enough they were right. After removing that one file called JT 9 , I again downloaded Ver 1.8 ... still it would crash ,when it starts ... again when I tried to remove Ver 1.8 this one lone JT 9 file would stay.
    If I'd try to load Ver 1.7 it would not load because of this lone Ver 1.8 JT 9 file ... once I removed this lone file ... I got Ver 1.7 to load and work OK.
    So I can get Ver 1.7 to work OK as long as this lone Ver. 1.8 file isn't on my PC.
    By the way if I delete Ver 1.7 from my PC it deletes all its files like it should ,but Ver 1.8 does not delete all files ,that JT 9 files stays until I use the Microsoft Software to locate it and remove it.
    Any ideas, why Ver 1.8 is not working for me ?

    Al
     
  2. W9AFB

    W9AFB Ham Member QRZ Page

    If you don't find an answer here, try over on the WSJTGROUP on yahoo groups.
     
  3. W9FTV

    W9FTV XML Subscriber QRZ Page

    I use linux, but looked throught the code. Try checking in the temp directories for a directory named similar to WSJT-X, underneath that you'll probably find a file called ".lock" Delete that and it should fix the problem.
    The existence of the lockfile signals to WSJT-X that the serial port is in use and to not fire up another instance.
     
  4. KB6KAX

    KB6KAX Ham Member QRZ Page

    I did go to the WSJT-X YAHOO GROUP but nobody had an answer to my problem.
    For whatever reason ,Ver 1.8 is now working on my PC.
    I did nothing special ,except use Ver. 1.7 for a week or so, yesterday I deleted Ver. 1.7 and downloaded Ver. 1.8 again ... it now does not crash on startup and works OK.

    I have no clue as to why Ver 1.8 didn't work before and why it is working now ??? Except as I said, that stray JT9 file , Stale Lock File.


    Al
     

Share This Page

ad: KF7PMW-1