Problem with Silicon Labs USB Driver Installation - for Windows

Discussion in 'Computers, Hardware, and Operating Systems' started by 9J2MM, Jan 17, 2018.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: MessiPaoloni-1
ad: Left-2
ad: Left-3
  1. 9J2MM

    9J2MM Ham Member QRZ Page

    I have an ICOM 7300 Amateur Radio Transceiver which has a USB port, for computer connection. Am currently running Windows 10 Operating System on an HP Desktop computer.

    I intend to use the USB cable for rig control using the Ham Radio Delux software, as well as digital modes, which all require a functional USB connection to a computer.

    I am experiencing problems with the installation of a Virtual Port (VP) to connect my USB to UART. I have installed recommended Silicon Labs CP210x driver, downloaded from the official Silicon Laboratories website. I am using the recommended CP210x drivers version 6.7.0.0 for the VP and give an error message Code 10. it won't work. When l click on device manager the com virtual port allocated for the USB to UART bridge has a yellow exclamation mark. I have also reset the VID and PID as recommended in some forums.

    What is interesting is that the installation has created two OEM.inf files (OEM28.inf and OEM40.inf) and both seem to be in use. I have noted that the system registry does actually recognize both files as active drivers for the silabvcp.inf. I have further tried to uninstall the Silicon Lab drivers and delete these OEM files with silabenm.sys and the associated files and fails to delete as they are in use.

    I am using an HP 280 G2 Minitower business PC running Windows 10.

    I have also tried to uninstall the silicon lab software/program and cannot be located in features and programs so that l could delete the above files manually.

    I have been grappling with for the past six months.

    So, the problem appears to be essentially one of Windows not accepting or loading the driver, when this is done and the com port created, the rest should (hopefully), be relatively straight forward.

    Please note that I have, over the past six months, attempted to install the CP210x driver on various laptops and desktops, on Windows 10 as well as Windows 8.1, and always experience the same problem (driver installation failure).

    Please find attached herewith, a number of computer screenshots, as well as the CP210x driver, which I hope you may find useful in ascertaining the exact problem and providing a solution.

    I have installed TeamViewer and am quite happy for you to log in remotely and have a look at the problem.
    Thanks in advance for your kind assistance and help.
    Regards,
    Mupanga Mwanakatwe (9J2MM)
    Lusaka, Zambia
     

    Attached Files:

  2. KD3WB

    KD3WB Ham Member QRZ Page

    Try the Icom driver. Click "Agree" at the bottom of the page.

    https://www.icom.co.jp/world/support/download/firm/IC-7600/usb1_20/

    Don't connect the cable until the driver is installed. Also, be sure to let the zip file create folders for the files, so that the installer can find the files it needs to perform its function. The executable should be in the "Driver" folder.

    Ben
     
  3. 9J2MM

    9J2MM Ham Member QRZ Page

    Hi Ben.
    Thanks for the link and advise.
    Have done as advised, to no avail.
    I am still failing to install the driver.
    Is it possible for someone to assist by logging into my computer using Teamviewer?
    Thanks & regards,
    Mupanga
     
  4. KD3WB

    KD3WB Ham Member QRZ Page

    Please repost with the contents of "C:\Windows\dpinst.log". If the file is large, just scroll to the bottom and post the last fifteen or twenty lines. Be sure to include the line that starts with
    "INFO: Command Line" and any line that starts with "ERROR".

    Ben
     
  5. 9J2MM

    9J2MM Ham Member QRZ Page

    Hi Ben,
    Please find herewith, the uploaded DPINST.LOG file.
    I trust the same will be insightful and look forward to your further assistance.
    Thanks for the advise thus far.
    Regards & 73
    Mupanga (9J2MM)
    Lusaka, Zambia
     

    Attached Files:

  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    There is a newer version 6.7.1

    New features/Enhancements
    -------------------------
    Added certification for Windows 10 Preview (Note: Windows 10 only; use v6.7 for Windows prior to Windows 10)

    Good Luck
     
  7. 9J2MM

    9J2MM Ham Member QRZ Page

    Have downloaded and attempted to install the latest certified Win 10 driver version from the Silicon Labs site, but alas, no luck!
    Please see the attached screen shots.
    Thanks & regards,
    Mupanga (9J2MM)
     

    Attached Files:

  8. KD3WB

    KD3WB Ham Member QRZ Page

  9. KA9JLM

    KA9JLM Ham Member QRZ Page

    Have you tried plugging into a different USB port. A USB2 port would be best.
     
  10. K6CLS

    K6CLS Ham Member QRZ Page

    he didn't get that far. the rule is install drivers first, always. then connect the USB.
     

Share This Page

ad: AlphaRF-1