Problem using EchoLink with my Iphone and Ipad

Discussion in 'Echolink/IRLP Tech Board' started by NG1P, Dec 5, 2011.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: MessiPaoloni-1
ad: L-MFJ
ad: Left-2
ad: Subscribe
  1. NG1P

    NG1P Ham Member QRZ Page

    I see this question was asked earlier this year. But here we go again. This will be a little bit deeper.

    We have a local Echolink repeater that has been up and running for many years. Recently I tried to connect to it using my Iphone and got a "Cannot connect to XXXX-R - Timed out" error. From my Iphone I can connect to my Echolink node and any others that I normally connect to. Here is the strange part using my Windows PC at home I was able to login to this -R with no problem. Going back to my Iphone and connecting to my home Wireless "not 3G" this is the same network my PC is running on and again I get the "Timed out" error and can never connect. Changing my Iphone to go direct "no relay or proxy" and setting up my port forwarding to point at my Iphone IP address I still get the "Timed out" error. At this point we have no difference from my home PC to my Iphone I even setup with the same IP as my PC just to make sure. The Windows PC works but the Iphone doesn’t at least for the –R in question.

    Now since I can connect via the same network using a Windows PC and using the same login I would automatically assume that all users types are allowed at this -R. I contacted the repeater owned and verified that the security allowed for such a connection and it did.

    The next thing I noticed was the Echolink version running on this -R was old didn’t have the latest version. So we got that upgraded to 2.0.908. Great I thought for sure this must be the issue but after upgrading I am seeing no change. I still get the "Timed out" error. Just to make sure I'm not crazy I had a local ham try his IPad from his home and work wireless and he too got the same results. He also gets the "Timed out" error. He was able to connect to my Echolink node and any others that he tried. This same ham loaded Echomac on his Mac and gets the same error but again can connect to others with no problem. I had a ham co-worker load Echolink on his Verizon Iphone "I have AT&T" and he also saw the same results. So is this a packet header difference from MAC, Iphone, IPad to Windows? Its all on the same ports.. Very strange…

    My Next step...Looking at how this -R network is configured:

    The first thing I wanted to do was to varify how the port forwarding was setup. Since the Windows OS’s with echolink are working one would assume that this must be setup right? It turns out it’s not. This -R is using Fairpoint as the ISP and the provided all in one (router,DSL and wireless) made by Clear Access model number SR300N. From what little documentation I can find on this ISP type dsl/router is it uses Dynamic Port forwarding so it listens to the tcp/ip sessions that are outbound and makes assumptions on that data to determine what to do with the inbound reqest in this case port 5200. It also uses a firewall and I’m assuming that’s what’s blocking the iPhone, IPad and MAC connections.

    So at this point I think we have three options:

    1.) Have the ISP setup the port forwarding "This could be like pulling teeth" Since this is an ISP supported all in one solution you don’t get access to this dsl/router (I may be wrong here we still need to call them)
    2 .) Replace this all in one dsl/router with just a dsl modem and supply our own router and have some control to setup the port forwarding/firewall
    3.) Get a new ISP

    Any other thoughts here? Anyone seen this one?
     
  2. NG1P

    NG1P Ham Member QRZ Page

    Option 1 was the fix for this one. Was able to login to the all in one dsl/router and set the ip address of the echolink computer to the DMZ host and things are working now. The only other option that this dsl/router had was port triggering "no port forwarding" in past settle I have found port triggering as intermitant so the DMZ host was the best option with a static ip assigned to the echolink pc running it's own firewall.

    Hope this posts helps others with the same issue
     
  3. VE3OBP

    VE3OBP Ham Member QRZ Page

    We have this exact sam problem! I have a cable modem going to a switch to separate my personal "home" computers from the echolink computer. Each pc is, in turn, behind its own firewall/router. We have no problems connecting into or out of our echolink system to any laptop, pc, etc...except apple users! Ipod and Iphone users always get this timeout when trying to connect to our repeater node. Attempting to connect out from the radio to an Iphone yields a "no route availabl" or a timeout. So if I understand your solution correctly, you basically removed the firewall in the router by putting the echolink computer into the DMZ? The only issue I have with that is that your echolink pc is now open to hacking is it not?

    John
    VA3BL
    VE3OAK/R 147.015 Oakville ontario
     
  4. KF5FEI

    KF5FEI Ham Member QRZ Page

    OK, trying to read the OP was giving me a headache, but I did glean you are using a Clear modem / router. Yes, you probably have to set up port forwarding to use Echolink, no mater which device you try it with. The port configuration on the Clear hardware is pretty goofy. Did they ever fix it so you could change the default password from something other than Motorola?

    We tried their service very briefly, and for VOIP applications, the latency was so bad our remote phones would randomly unregister / reregister every so often. We threw in the towel and switched back to DSL and everything worked fine.

    Just for grins, does Echolink work fine using the 3G network? Turn off your WiFi in your phone settings and see. I use Echolink on my iPhone all the time on 3G networks without issues.
     
  5. NG1P

    NG1P Ham Member QRZ Page

    Yes the pc is more open to hacking but as I stated the pc is running a firewall.
     
  6. N4LPK

    N4LPK Ham Member QRZ Page

    I have a similar problem. Except I can connect with my iPAD but not my iPhone. I tried it turning off my wireless connection and going 3G. It told me it couldn't find the relay servers. So that didn't work for me. I have a iPHONE 4GS. Not sure if that has anything to do with it.
     
  7. AD8T

    AD8T Subscriber QRZ Page

    My son who is a ham, cannot connect to my -L node using his iPhone nor his iPad. Another ham friend nearby cannot connect to HIS own -L node using his Android phone, either. However, EVERYONE CAN connect using those devices to a local -R. That -R is linked 24/7 to my node, so we have that workaround; hence I'm not going to stew about it nor delve into the intricacies of this problem. I spent 20 years in IT and I've done my time in TCP/IP Heck. Someone who isn't jaded and entirely sick of this kind of issue can probably solve it if they are willing to spend enough time!

    I am sorry I am not contributing anything to the OP issue, except to confirm it is apparently a common problem, as I expected...when all COMPUTERS can connect with no problem, and I can control my HF rig remotely with no problem, clearly it isn't a router problem per se, so this is where I get off...been there, done that...not gonna fiddle with my router or change my ISP and mess up a system that works fine in every OTHER respect except this one issue with cell phones. If it were something critical to my needs, I would fight this battle...but it isn't. It is technically of interest to me, but not enough to carry the torch. We all made sure it isn't a sysop parameter like number of conferences set too low. After that, there was no obvious solution. I am glad to see in previous posts that some others are getting at the root of the problem. :)
     
  8. KA9JLM

    KA9JLM Ham Member QRZ Page

    There are a lot of people that Jailbreak their Iphones in order to get around limitations of their ISP.

    You would think that you could use all of the ports TCP 5200, UDP 5198 and UDP 5199, Needed for Echolink.
    But many times the ISP blocks the needed ports, Then you have to break the laws of the Internet service agreement by modifying the system software by Jail breaking, In order to make it work.

    Some ISPs will unblock your needed ports for free or for a fee if you ask.

    Looks like TRUE unlimited internet service is becoming a thing of the past for most ISPs.

    Using a proxy server is a work around, but then you have another server involved and many proxy servers have time limits, unless you setup your own.
     
Thread Status:
Not open for further replies.

Share This Page