Problem getting WSJT-X to work w ICOM-7300 on mac OS Sierra 10.12.6

Discussion in 'Computers, Hardware, and Operating Systems' started by AB1WE, Oct 8, 2017.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: MessiPaoloni-1
ad: Left-3
ad: L-MFJ
ad: l-assoc
ad: Subscribe
  1. AB1WE

    AB1WE XML Subscriber QRZ Page

    I'm getting set up to try digital modes and ran into this problem. I followed WSJT-X installation steps, adjusted shared memory on my mac, got/installed the Silicon Labs driver, watched several YouTube videos regarding ICOM-7300 settings, the radio & audio settings in the software. But when I hit the test button I get "Rig failure Hamlib error: Communication bus error while getting current frequency". Any suggestions? I've ordered a new USB cable just in case that's the problem, but perhaps someone out there has run into this and discovered some solution.

    Thanks, Phil AB1WE
     
  2. KA8NCR

    KA8NCR Ham Member QRZ Page

    Hamlib installed and working? You should be able to communicate with your radio through the serial port with rigctl outside of WSJT-X.
     
  3. AB1WE

    AB1WE XML Subscriber QRZ Page

    Thanks. No, I didn't see anything about installing Hamlib, and IC-7300 doesn't appear on Hamlib listed of supported radios. So, I'm thinking WSJT-X and MacLoggerDx do not require it.
     
  4. AB1WE

    AB1WE XML Subscriber QRZ Page

    Here's the error I'm getting, so perhaps Hamlib is the problem?
     

    Attached Files:

  5. AI6AK

    AI6AK Ham Member QRZ Page

    What are your audio settings? I used to use my MacBook for WSJT-X and most of the time I had issues was because my audio wasn't set properly. I'd send you a Word doc I created that had all the settings for using a Mac but my house was recently burglarized and the thieves made off with my old Mac. I use a cheap Windows 10 laptop now for digital stuff. The audio always had to be set to CODEC on my MacBook.
     
  6. AB1WE

    AB1WE XML Subscriber QRZ Page

    Thanks for your reply. I think my audio is set up okay and is using CODEC. Hoping the problem is just the USB cable. I should know in a couple of days when new one arrives. Some work ok for power but not for data, so I’ve read.
     
  7. KA8NCR

    KA8NCR Ham Member QRZ Page

    In the config, under the Rig tab, what is set for the method of communicating with the radio?
     
  8. KA8NCR

    KA8NCR Ham Member QRZ Page

    If it is working, you should be able to see it under /dev/tty.usbserial. Open up a console and 'ls -l /dev/tty*'. If it isn't there, that would be the problem.

    If it is there, you could try to communicate with a standard serial device. In a console, you can use 'screen /dev/tty.usbserial <port-speed>'. I am using /dev/tty.usbserial in a generic sense, the name will likely be a bit different. If screen isn't going to cut it for you, Minicom is available from Macports or Homebrew.
     
  9. AB1WE

    AB1WE XML Subscriber QRZ Page

    I've tried None and USB, but neither help.
     
  10. AB1WE

    AB1WE XML Subscriber QRZ Page

    I tried changing default CI-V Transceive setting ON to OFF, but didn't help.
    Also, now using a brand new USB A/B cable.
     

Share This Page