Operating Windows 7 Remote with SignaLink Sound Modem

Discussion in 'Computers, Hardware, and Operating Systems' started by N4CVX, May 26, 2021.

ad: L-HROutlet
ad: l-rl
ad: L-Geochron
ad: abrind-2
ad: L-MFJ
ad: Left-3
ad: HRDLLC-2
ad: MessiPaoloni-1
ad: Left-2
  1. N4CVX

    N4CVX Premium Subscriber QRZ Page

    Here's a weird -- well, sort of off the wall -- question for the group. I have a Win 7 Prof PC set up in the Ham shack, which is a separate building from my house. I use Reminina (the remote control on Ubuntu Linux) to access the Win 7 PC from my Ubuntu WorkStation. I have a SignaLink set up with Vara-FM to drive the WinLink system on the PC.

    No problemos running it when I am physically at the PC. However, when I remote in, the Windows system does not "see" the SignaLink. Thus no way to run the VARA-FM connection to the local WL site (WC4EOC-8, part of the www.wcares.org ARES system).

    Any ideas? I am almost exclusively a Linux geek -- have Linux Certification as a System Administrator which pays for my ham gear, so my knowledge of Windows kind of stopped at Windows for Workgroups back in the late 1990s. Appreciate any advice or recommendations.

    Perhaps, going with a complete Remote Administration rather than the remote connection?

    73
    Dave, N4CVX
     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    Windows RDP works very well, Windows required.

    AnyDesk may be your best option using Linux.

    There are some other work arounds, But reliability is in question.
     
  3. N4CVX

    N4CVX Premium Subscriber QRZ Page

    Thank you for your response. Yes, The Reminina appllication for Linux uses the Windows RDP Protocol to establish a secure connection. It works well for me and I have 4 different Windows 7 PC's attached to this Ubuntu WorkStation. It is only the one with the SignaLink attached as an "external Soundcard" which is either blocked or not recognized. I'll tinker with the Windows PC firewall settings and see what is up with that. 73, Dave
     
  4. KC3PBI

    KC3PBI Ham Member QRZ Page

    Are you sure the RDC server isn't (attempting to) temporarily reroute audio, much as it is doing with the display?

    I'm not a regular RDC user but I know remote audio routing is one of the features in there. Is windows hiding audio devices that a remote user wouldn't hear?

    Maybe try a simple VNC connection (which won't attempt any audio bridge) and see if you get normal operation.
     
    N4CVX likes this.
  5. N4CVX

    N4CVX Premium Subscriber QRZ Page

    Thank you for the response. I'll try that. I have to go out to the PC and check the firewall settings and set up a VNC server on it. I'll give that a try and check back here tomorrow. Good idea about the audio being hidden.
    73
    Dave
     
  6. NG1H

    NG1H XML Subscriber QRZ Page

    I don't have recent experience but routing audio through RDP and getting it to work at all much less acceptable timing used to be a PITA. Citrix used to be a little better but still had timing issues. If WFView (Just released. And free.) will work with your radio this may be a solution. Supposedly it will work with heterogenous setups. One of their design criteria was to optimize audio routing.
     
  7. KC3PBI

    KC3PBI Ham Member QRZ Page

    I suspect this is the opposite problem: the remote control software is trying to inappropriately route the audio into the remote session, when it should be leaving all audio paths unchanged on the target machine.
     
  8. N4CVX

    N4CVX Premium Subscriber QRZ Page

    WFView for Linux is still have major growing pains for several reasons and I've tried it both as root and user with nil useful results. I'm going to be working on the PC to make sure the RDP access does not quench the local audio. That will require some firewall tinkering. Back at ya later.
    73
    Dave
     
  9. NG1H

    NG1H XML Subscriber QRZ Page

    Whoops. You're right. I missed that part.
     
  10. N4CVX

    N4CVX Premium Subscriber QRZ Page

    I fixed the problem. Seems that default setting in RDP access from Linux is to set the sound to "Local" (with a variety of quality levels). Well, "local" means my Linux workstation, NOT the remote Window$ computer. I reset the RDP default for the remote PC to allow "Remote" sound and that cleared up the blocking of the "local" (the "remote" sound) sounds like backassward logic but it is what it is ("fahi ma fahi" say the Persians). Now working well and I have those settings locked in for the connection from my workstation to the PC running WinLink + Vara-FM. Other computers in the Ham shack are set to different tasks which do not require a SignaLink external device. I appreciate the advice from the group. Best 73, Dave
     
    KA9JLM, NG1H and KC3PBI like this.

Share This Page