Noise/Static in my TS 520

Discussion in 'General Technical Questions and Answers' started by WB7PNC, Dec 20, 2018.

ad: L-HROutlet
ad: l-rl
ad: l-gcopper
ad: Left-3
ad: abrind-2
ad: Left-2
ad: l-BCInc
ad: L-MFJ
ad: QSOToday-1
  1. WB7PNC

    WB7PNC Ham Member QRZ Page

    For some time when talking with my brother in CW mode, I have noticed a slowly building up and a sustained amount of noise and static. At first, I thought it was the band, 40m. Then the other day I started to use the rig, which I leave on 24/7 and all I could hear was noise/static. Tried other bands and except for a lower loudness was the same. The normal 25 kHz VFO beat to zero dial could be barely heard. I disconnected my tuner with no change. Then disconnected my ant with no change. I examined the top and bottom circuitry and blew things out still there was no change. Tapped on capacitors with no change. While the rig was on its side and running with no heaters, started to set in back in normal position. The top and bottom covers were off. I noticed for a moment the noise and static stopped about halfway through this movement. Tried to repeat it and couldn't. Checked all the grounding solder joints and found nothing. With the RF gain fully CW, SWR meter at +20-+30 over. Switched to USB and LSB with a reduced level of same.
    This all started with no movement to the rig, just another regular day of operation. However, I think that something other than ground is causing the problem as it seemed to build up over a long period of time.
    Don't have any test equipment other than signal gen, 5 mhz scope and VOM. Hoping that someone might be able to help here.
    Thanks a bunch
     
  2. K0OKS

    K0OKS Premium Subscriber QRZ Page

    It sounds like a loose connection.

    The first thing I would try is to looser and re tighten all the screws holeding all the boards into the radio. They screws make the ground connection, and they do get loose. If you have contact cleaner you can put a little on the screw holes when you do this. You could also try to re-seat all the molex connectors (white cable connectors) between the boards.

    If this doesn’t solve it then look closely for bad solder joints, which means removing the boards. You might also join the Kenwood Hybrid mailing list. Lots of knowledgeable people on there who can point you in the right direction quickly.
     
    K7TRF likes this.

Share This Page