MD380 DMR Radio Problem

Discussion in 'VHF/UHF - 50Mhz and Beyond' started by KD2FIQ, Jul 21, 2016.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: L-Geochron
ad: Left-2
ad: abrind-2
ad: L-MFJ
  1. W8RLM

    W8RLM Ham Member QRZ Page

    Mine is less than 30 days old with extended warranty. I would upgrade but already bought spare batteries and other junk. So asking for exchange. Now I'm thinking dual band mobile unit too.
  2. N8EKT

    N8EKT Ham Member QRZ Page

    Welcome to the world of code plug based radios

    The first thing I learned when I started working on commercial radios was to read the code plug FIRST

    Its much easier to modify the radio's existing code plug and reload it than start from reset
  3. N1GMV

    N1GMV Premium Subscriber QRZ Page

    Welcome to DMR, I am usually on TAC310
  4. WB2LBV

    WB2LBV Subscriber QRZ Page

    Old thread, but since it was posted the popularity of this radio has increased tremendously and there is a lot more support for it- MD380Tools and plenty of online support groups. If you have an issue with a 380 it's pretty hard not to find the answer with a bit of searching.
  5. KD6JSM

    KD6JSM Ham Member QRZ Page

    The radio was up and running. went to install latest version of 380 Put radiotoolz. followed instructions and came time to flash. Put radio into receive mode got green/red flashing light and flashed. When that was compelete stopped and shut radio off and turned it back on. The flashing light is supposed to stop. didn't happen. Have read all the forms and helps and getting no where fast. Tried every combination of buttons and knobs without and change. Screen is still dark and green/red light is still flashing.
  6. KG5ZID

    KG5ZID Ham Member QRZ Page

    It's now 5 years later and my radio is the MD-UV380 but I'll go ahead and add my $0.02 worth to the list. First of all, G8HIK is correct - there is no chip in the TYT 380 cable, it's straight through. If you have a USB breakout so you can access the pins, you can check it out with an ohm meter. I found this out the hard way. When I first got my 380 a couple of years ago I thought "I already have one of those cables, I'll just use the old one". Of course it didn't work! After a LOT of study and false starts I was able to get the thing programmed for my repeaters, hotspots, etc and it has been working fine with my Win10 laptop until this week. I acquired a second hotspot and set it up for a different frequency to use with my Fusion radio. A few days ago I decided to add a new zone and channels to my TYT MD-UV380 so I could use it with either hotspot (or local repeater). Unfortunately I wasn't able to get CPS to talk to the radio. Suspecting a software problem, I dug an old XP laptop out of the bin, installed CPS and the TYT digital radio USB driver downloaded from the TYT website. It worked fine. A closer examination of the TYT 'driver' revealed the problem. This package actually installs STM's DeFuSe software for their line of microcontrollers. Earlier last year I acquired a few of the ultra-cheap, arduino-like Chinese knock-off "Blue Pill" micros and had been tinkering with them and their associated bootloader software. Evidently that was able to sufficiently confuse Win10 that CPS was no longer able to talk to the STM micro inside the 380 radio. At any rate, I'm back in the code plug programming business and the new knowledge acquired regarding the presence of an STM microcontroller inside the radio gives me a whole new set of rabbit holes to jump into and explore.
    KG5ZID Hardy

Share This Page