MD380 DMR Radio Problem

Discussion in 'VHF/UHF - 50Mhz and Beyond' started by KD2FIQ, Jul 21, 2016.

ad: L-HROutlet
ad: l-rl
ad: HRDLLC-2
ad: Left-3
ad: abrind-2
ad: MessiPaoloni-1
ad: Left-2
ad: L-Geochron
ad: L-MFJ
  1. KD2FIQ

    KD2FIQ Ham Member QRZ Page

    I just received my MD-380 a couple days ago. Somehow I think I messed up the programming big time. Unfortunately, I attempted to upload to the radio a program from the software without first downloading what was already on the radio and working with that. I think this was the start of my problems. Then the radio would turn on but read "unprogrammed". Then I couldn't get it to go to USB programming mode at all. When the USB programming cable was not attached it would emit a continuous tone. I tried to upgrade the firmware using the hold down the two buttons while turning it on. This worked according to the utility program but when I go to turn on the radio, nothing happens but the LED flashes red / green repeatedly. I am really stumped as well as feeling quite foolish for messing it up. Any ideas would be quite appreciated. I search the web but could not find a way to do a hard reset or factory reset

    (I also posted this over on radio reference)
  2. KD2FIQ

    KD2FIQ Ham Member QRZ Page

    As a follow up......I was able to fix everything. Turns out my laptop was a little fussy about the USB ports. I switched ports and then the firmware updated fine as well as the programming software. So I am sorta back to square one on figuring out how to program it.
    K9ASE likes this.
  3. K0RGR

    K0RGR Ham Member QRZ Page

    I assume you're using the Tytera software with it? I had lots of fun getting the proper USB driver for the radio loaded, but once I did, all was well. The radio programming cable doesn't show up as a serial port, rather, the whole radio shows up as a device. I would not attempt to program the radio without the TYT programming cable.

    You need to find or build a code plug that will work for you. I would contact the folks here - no doubt somebody there already has a code plug you can load into the MD380 with the TYT software and be on your way. You will need a DMR ID number in order to set up the code plug. If nothing else, a sample code plug will show you how to set up the radio's zones and talk groups, so you can roll your own if you have the time and the repeater info.
    WA4TOG likes this.
  4. KF5FEI

    KF5FEI Ham Member QRZ Page

    Don't feel bad -- DMR is a bit more complicated than an analog HT. Ladyada has a good tutorial on programming the radio:

    I tried a codeplug from a local guy first, but it was full of odd stuff that didn't make sense, so I started a with a clean file on the PC and Googled what I needed to get it going. Now that I've done it myself, it is easy to understand. There are also a number of useful features that people don't know about or don't enable, that make it easier to understand what is going on.
  5. KD2FIQ

    KD2FIQ Ham Member QRZ Page

    Thanks for the feedback everyone!! I certainly see how it is more challenging than programming a standard HT. Also need to wrap you head around the way it works. Thanks for the link!
  6. G8HIK

    G8HIK Ham Member QRZ Page

    Hello all.

    I'm having a problem with programming my 380. When I plug the cable into the computer, it pops up a message saying "the last device you connected appears to be faulty", and the software says that the USB is not connected when I try to read from the radio.

    I've been using the cable for about 6 months without a problem, but now it won't work.

    I was told that the cable has no internal circuitry and is just a straight through wired cable, but if that's the case, why is the computer detecting it and reporting a problem ?, there must be some sort of circuit inside.

    I'm running Win 8.1, I've tried it on a Win 10 machine with the same result.

    Any help would be appreciated.
  7. KD2FIQ

    KD2FIQ Ham Member QRZ Page

    The cable is not straight through. That's what is in the chunky USB end. It converts the signal from USB to serial protocol. Or at least that's the way it does it on most other programming cables. Try a different USB port. Worked for me!!!

    I am slowly getting new problem I have noticed is that if I key down for a repeater that is out of range, the HT locks up and blinks red on the LED. Almost like it won't give up until the repeater gets back to it. I don't know if there is a time out option for unresponsive repeaters or not.
  8. G8HIK

    G8HIK Ham Member QRZ Page

    There seems to conflicting information on the Web as to whether the cable is 'Straight through' or not, for example,

    I agree with you that there is a chip in the USB plug, or windows wouldn't detect a problem when it is plugged in.

    I've tried different USB ports, and a different computer with the same results, so I think the cable is faulty.

    I haven't had the lockup problem you describe, if I try to contact a repeater that is out of range, the red light flashes 4 times and the radio beeps and goes back to receive.
  9. KF5FEI

    KF5FEI Ham Member QRZ Page

    On my MD-380, Windows shows nothing when you plug the cable in. Once you connect it to the radio and turn the radio on, you see a USB device.
  10. G8HIK

    G8HIK Ham Member QRZ Page

    I borrowed a cable from a friend and it worked fine, which confirmed that my cable was faulty.

    I decided to cut it open to see if I could repair it. What I found was an un-populated circuit board with the wires connected directly to the connector pins.

    After a close examination with a magnifying glass, I found a single strand of wire short circuiting the +5V pin to the -Data pin.

    I cleared the short and re-assembled the connector, the cable is now working fine.[​IMG]

    I can now confirm that there is no chip in the connector and the cable IS straight through wired.

Share This Page