Mac Mini vs Patience

Discussion in 'OS: Mac OS' started by NP4SS, Jul 30, 2019.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: K5AB-Elect-1
ad: Left-2
ad: MessiPaoloni-1
ad: L-MFJ
  1. NP4SS

    NP4SS XML Subscriber QRZ Page

    Greetings

    I’m currently trying to work digital modes on my MacMini, but I’m very confused …...

    So, Current hardware TS-870 MacMini 2 w/ Mojave 10.14.16 CAT Cable

    Signalink (with acc cabling for kenwood, audio cable, and USB cable)

    Questions:

    If I work thru CAT, do I need Signalink Sound Card?

    If got no red flags after drivers update Security & Privacy Pane of System Preferences (nothing physically connected on USB port); where to look to double check drivers were “properly installed” on Mac

    Under TERMINAL anyone had tried out csrutil disable" for Mojave?

    Why? well I don’t see SLAB_USBtoUART option within port drop downs menus, nor the audio output options (codecs) but Built in or HDMI (I’m utilizing a TV as display)

    I have installed – then uninstalled

    FLDIGI: nothing happens, unable to RX/TX – code decode signals.

    Under Rig Control Menu I have tried

    - Hamlib (downloaded 3.0ish version),

    - RigCat (downloaded the xml profile for the radio) w/o success.

    WJST-X: almost identical issues like the ones described above.

    RumLog: no luck either

    So, I see a pattern – I dunno know what Im doing (hahahaha)

    So far the only app I’ve been able to use is MacLogger (demo version) – does control my rig w/o issues.

    Open to suggestions and some good old constructive critique.
     
  2. K7GQ

    K7GQ Subscriber QRZ Page

    Gosh, so many things ...

    I'mm not familiar with your rig, but I assume that the Signalink cables go to the ACC 2 and COM connectors - correct?

    With Mojave, you must allow the programs WSJT, FLDIGI, etc to have permission to use the "microphone" - aka audio in. This is accomplished in System Preferences/Security & Privacy/Privacy. Click on Microphone and add the programs by dragging their icon to the area on the right.

    When you installed the Silicon Labs driver, did you have the USB cable disconnected? If not, install again, then re-restart. Upon restart, you should see an "extension blocked" message and should immediately visit the Security & Privacy preferences and allow the driver to be loaded. It may be helpful to perform one additional restart afterwards.
     
  3. NP4SS

    NP4SS XML Subscriber QRZ Page

    So it goes as follows (answers)

    a) Signalink cables goes to the ACC 2 :)
    b) System Preferences/Security & Privacy/Privacy - previously done :)
    c) Silicon Labs driver - previously installed w/o peripherals connected ;)
    d) Extension blocked - no messages of such :(
     
  4. K7GQ

    K7GQ Subscriber QRZ Page

    Let's confine this to WSJT-X for the moment. In its' Preferences / Radio, you should be able to see a selectable serial port entry under CAT Control of something similar to "/dev/cu.SLAB_USBtoUART. If not, the Silicon Labs driver is not loaded.

    Check the contents of MacintoshHD / Library / Extensions for a file named SiLabsUSBDriver.kext. If not present, the driver is not installed.

    If the driver is present, then I'd assume that the loading of the driver is being blocked, regardless of the message (or no message). Upon restart, immediately visit the Security & Privacy preferences and allow the driver to be loaded.

    I'm not familiar with the "Mac Mini 2". Can you provide the model identifier (2nd line) from /About This Mac / System Report /?
     
  5. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    What CAT cable specifically are you using? Where did you get it? Is it a USB-Serial adapter?


    Yes. CAT provides rig control. SignaLink provides the audio path.

    There should be no need to disable anything.

    SLAB_USBtoUART is only visible if you have a Silicon Labs device. The 870S doesn't have built-in USB connection typical of newer rigs that use the Silicon Labs chipset, which is why I asked the questions above about the source and type of your CAT cable.


    We were all there once. :)

    So, if MLDX works, what ports do you have selected in MLDX? Are you certain it is working? Does the frequency follow when you change bands? If MLDX is working correctly, and it can see your CAT port to the rig, then there is no reason why everything else shouldn't be able to connect as well.

    However, keep in mind, only one program at a time can connect to the CAT port. So, if MLDX is connected, then that port is not available for other programs at the same time. However, MLDX (and RUMlogNG) can both share that port with Fldigi and WSJT-X via UDP/XML-RPC interfaces. Instructions on setting those connections up are available in both the MLDX and the RUMlogNG online manuals.
     
  6. K7GQ

    K7GQ Subscriber QRZ Page

    Good call! I assumed that the Signalink USB had a FTDI-compatible interface - not!
     
  7. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    The SignaLink should just show up as an USB Audio CODEC device. The OP mentioned looking for the SLAB_USBtoUART: this will only show up if he has a Silicon Labs device. The TS870S does not have a built-in USB hub (usually Silicon Labs devices), so either the CAT cable he is installing is a SILabs device, or is another brand (usually FTDI) in which case he shouldn't be looking for the SLAB_USBtoUART.
     
  8. NP4SS

    NP4SS XML Subscriber QRZ Page

    Understood

    Present as specified

    allowed

     

    Attached Files:

  9. NP4SS

    NP4SS XML Subscriber QRZ Page

    Bought on eBay to a reliable Ham KJ6ZWL, serial port to USB (Mac end). Indeed MLDX follows manual changes on radio and switches band w/o issues.
     

    Attached Files:

  10. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Then cu.usbserial-A....... is the device that you should be using in Fldigi and/or WSJT-X. However, note what I said above about two programs not being able to access that port at once. If MLDX is running with CAT control of the rig and then you try to access that port via Fldigi or WSJT-X, it won't work. The easiest way to configure going forward is to leave MacLoggerDX in control and configure your other programs to talk to it.

    See https://dogparksoftware.com/MacLoggerDX Help/mldxfc_wsjtx.html on how to setup WSJT-X to work with MLDX.

    For Fldigi, activate the UDP broadcast in MLDX and then setup Fldigi using the Configure, UI, Log, MacLogger tab to "Connect to MacLogger," put check marks at least by "Capture Radio Report" and "Capture Spot Tune."


    Hope this helps
     
    NP4SS likes this.

Share This Page