Loss of Receive using WSJT-X

Discussion in 'OS: Mac OS' started by K7GQ, May 5, 2019.

ad: L-HROutlet
ad: l-rl
ad: MessiPaoloni-1
ad: Left-2
ad: L-MFJ
ad: Left-3
ad: Subscribe
  1. K7GQ

    K7GQ Subscriber QRZ Page

    I've been recently bothered by an occasional loss of receive signal using WSJT-X 2.0.1 running with High Sierra on a MacBook Pro USB-connected to a TS-590SG. I would force receive to recover by briefly hitting the WSJT-X TUNE button.

    I thought this to be some undiagnosed issue with USB in general, and cabled around the USB hub directly to both of the MBP's USB port, without success. The MBP and hub is USB 3.0 while the Kenwood appears to have a USB 2.0 port.

    Today, there is nothing I have found to get WSJT-X to receive though the program transmits just fine. The trouble is, any other program using the same setup works just fine, such as fldigi, cocoaModem, and JS8CALL. I even made a PSK31 QSO just to prove how crazy this scenario is.

    The Sound Preferences panel within System Preferences shows audio coming through the CODEC.

    I am ashamed to admit that I did the very thing that most Windows users do - reinstall the program. No joy!

    Any thoughts from the Mac community?
     
    Last edited: May 5, 2019
  2. DL2RUM

    DL2RUM Ham Member QRZ Page

    Can you explain "loss of receive signal" with more details please? Do you see signals in the waterfall, or just no decodes? Is the correct Input sound card still selected in the WSJT-X Audio settings? As always, a screen shot could be helpful.
     
  3. K7GQ

    K7GQ Subscriber QRZ Page

    Hi Tom

    It is exactly that - a blank waterfall and zero-level receive signal level as shown attached. The same CODEC is chosen for each of the four mentioned programs; only WSJT-X fails to see the data.
     

    Attached Files:

  4. DL2RUM

    DL2RUM Ham Member QRZ Page

    As next, see the Audio settings in WSJT-X. Do you have still selected the correct sound card and the correct channel?
     
  5. K7GQ

    K7GQ Subscriber QRZ Page

    Yes, though the channel selection does not seem to matter here for LEFT, RIGHT, BOTH or MONO all have yielded the same results.
     

    Attached Files:

  6. DL2RUM

    DL2RUM Ham Member QRZ Page

    Now check your Audio-Midi-Setup options. Baud rate set to 44100? Audio not muted? Check the levels.
     
  7. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Double check your Privacy settings under the Security and Privacy pane of the System Preferences. Make sure that WSJT-X is authorized to access the microphone (the system sees the USB Audio device as a microphone).

    I had this issue just the other day where I had disconnected my USB cable, and when I reconnected it the checkbox to allow WSJT-X to access the microphone was unchecked. Took me about two hours to figure it out.
     
  8. DL2RUM

    DL2RUM Ham Member QRZ Page

    I'm not sure if this feature was already included in High Sierra.
     
  9. K7GQ

    K7GQ Subscriber QRZ Page

    Tom:
    I was running audio at 48kc but dropped it down to 44.1 - no change.

    Dave:
    High Sierra doesn't have that particular privacy setting that I think Mojave has. If something such as GateKeeper was blocking the audio, wouldn't the other three programs I tried also be affected?
     
  10. DL2RUM

    DL2RUM Ham Member QRZ Page

    Hmm,
    do you have rebooted you Mac? Do you see audio signals when you switch the input to the microphone (if applicable for your Mac)
     

Share This Page