ad: cq2k-1

linux usb wireless device,no drivers?

Discussion in 'Computers, Hardware, and Operating Systems' started by W9WQA, Mar 30, 2020.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Subscribe
ad: L-MFJ
ad: Left-2
ad: FBNews-1
  1. KA9JLM

    KA9JLM Ham Member QRZ Page

    I am looking for the model number now.

    I should be able to guess and pull one out soon. Please Wait .................


    upload_2020-3-31_13-22-47.png
     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page


    You should stick to Windows, Point and click.

    Plug And Pray.
     
  3. W5UAA

    W5UAA Ham Member QRZ Page

    Yes, well, today's versions of Linux are getting better at scanning for hardware at bootup and automatically loading the appropriate kernel module (driver) for you. Have you looked at your ring buffer (dmesg) to see if it's recognizing anything about your wireless device? Maybe there's an error message there that tells you what's wrong? And most of the time, the only time you may have to manually load kernel modules (drivers) is if you need to use really old hardware. How old is this wireless device you're trying to use? Without even knowing the chipset you're trying to use, it becomes nearly impossible to find out what the kernel is seeing about it right now and doing anything about finding and installing the correct driver for it with out it being "try it and see if it works", failing, removing it, and trying another one. That's no way to go about trying to get it to work. So my suggestion for you, especially if you're not familiar with commands to load kernel modules and/or the configuration files to modify to load them on bootup, you may just want to not use the device you're trying to use and go with a newer one that the kernel programmers still scan for on bootup and load the correct driver for. It makes it a lot easier -- use plug and play devices. Not all devices are plug and play.
     
  4. W5UAA

    W5UAA Ham Member QRZ Page

  5. W9WQA

    W9WQA Ham Member QRZ Page

    i sent one back last month for this reason, no cd drivers.
    no the wont work wo them.
    this one is a tp-link......note.....
    cd has drivers for win and mac, wht not linux???

    this one is a tp-link.

    just got it. dont know history. this from search,,now
    TP-Link is the world's number one provider of consumer Wi-Fi networking devices
     
  6. W9WQA

    W9WQA Ham Member QRZ Page

    what i really need to know is...why does the cd not hold the driver but they say i should go to site and download it???
    the cd has drivers for win and mac.
    can i download the drivers on my win 7 comp and then use them on linux,ubuntu 14...?
     
  7. W5UAA

    W5UAA Ham Member QRZ Page

    Answer to 1st question: so you'll be using the latest driver.

    Answer to 2nd question: yes, just transfer the file (probably a *.tar or *.gtar file) using a thumb drive. But I'll just go ahead and tell you right now, it's not going to be just "double click" the file to install a driver on Linux.

    Good luck.
     
  8. KA8NCR

    KA8NCR Ham Member QRZ Page

    Because the number of combinations of Linux architectures and TP-Link hardware revisions would fill a CD with hundreds of .rpm, .deb and source tarballs with no clear way of determining which one you should use. They want you to go to the web site so they can steer you to the right driver package.

    TP-Link uses RealTek chipsets which has timely and broad support in Linux. Normally, you do not need drivers unless your system is on the periphery of either being very dated or bleeding edge.

    Downloading it from Windows 7 host onto a USB drive and transferring it to your Linux host will work. But seeing that you're running Ubuntu 14, you're likely going to have to compile the drivers yourself.
     
  9. W9WQA

    W9WQA Ham Member QRZ Page

    ok, understood. i like that 14.2 because its been so good and trouble free. its a desktop with 2 old 'square "monitors. i have mint on a laptop but i really feel that its too much like win 10 that i hate so i have thinking to do. im not junking ubuntu 14! shame the old wifi worked great...
    tnx guys...
     
  10. W9WQA

    W9WQA Ham Member QRZ Page

    sooo, update. when that one was lost in usps i in my frustration, ordered another one, different place.
    it sat here unopened a few days because i expected nothing. today i opened it.
    it looks the same. i plugged it in and tried the cd,no luck...but

    i noticed the wifi indicator was working! i connected here and a few other sites.
    IT WORKS WITHOUT ANY CD DRIVERS !! just as a friend said it should.

    no im not trying the other one again, not pushing my luck.

    tnx again...73.
     

Share This Page

ad: ARR