Linux Not Communicating With Radio

Discussion in 'Ham Radio Discussions' started by AD7GR, Dec 22, 2017.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: Left-2
ad: FBNews-1
ad: OK1UUad-1
ad: Left-3
  1. AD7GR

    AD7GR Ham Member QRZ Page

    I've installed Linux Mint Cinnamon 18.3 on my HP pavilion computer and have most running well.
    My problem is that Linux is not is communicating with my TS-590s.
    I have worked with creating symbolic links but still no go... probably something I am not doing or that I did that is getting in the way. I do belong to tty and users groups.

    Any help?
    Ed - ad7gr
  2. DK7OB

    DK7OB Ham Member QRZ Page

    Do you see any error messages?

    What's the user/group of the USB device? On Ubuntu it's

    rw-rw---- 1 root dialout 188, 0 Dez 22 17:10 /dev/ttyUSB0

    So you must be member of the dialout group.

    Do you see something in the system log when you plug in the USB cable?
    KK5JY likes this.
  3. KK5JY

    KK5JY Ham Member QRZ Page

    My SG can talk to any of my Linux machines... the drivers are part of the kernel by default. I use the serial port and sound device.

    As the previous post mentioned, you may need to be a member of "dialout" to open the USB serial port.

    What software are you using to try to speak CAT with the radio? Fldigi? Something else?
  4. AD7GR

    AD7GR Ham Member QRZ Page


    What do I enter into the terminal in order to get the USB user/group?

    I see this in the System Log... and that's the what I used for the symlink...
    Dec 22 08:58:58 linux-desktop kernel: [13741.585710] usbcore: registered new interface driver cp210x
    Dec 22 08:58:58 linux-desktop kernel: [13741.585757] usbserial: USB Serial support registered for cp210x
    Dec 22 08:58:58 linux-desktop kernel: [13741.585888] cp210x 1-1.2:1.0: cp210x converter detected
    Dec 22 08:58:58 linux-desktop kernel: [13741.589826] usb 1-1.2: cp210x converter now attached to ttyUSB3

    I added membership to the dialout group also but no go.
    I've tried FLdigi and also SKCCLogger via Wine.

    Ed - ad7gr
  5. KK5JY

    KK5JY Ham Member QRZ Page

    Part of the problem with fldigi (and basically anything based on hamlib) is that it has too many settings.

    Here are the settings from my SG:
  6. KK5JY

    KK5JY Ham Member QRZ Page

    Something like this:

    $ ls -l /dev/ttyUSB0
    crw-rw---- 1 root dialout 188, 0 Dec 22 12:56 /dev/ttyUSB0

    In this example, the user is root and the group is dialout.
  7. AD7GR

    AD7GR Ham Member QRZ Page

    Okay... yes I have that. Still no go though.
    This time in the RigCat Tab under Rig Description file: I have ig-not-assigned.xml The choices for rigs has disappeared.
  8. KK5JY

    KK5JY Ham Member QRZ Page

    I believe you will have better luck using the Hamlib tab.

    Depending on what version of hamlib is installed on your machine, you may want to upgrade it to get better support. Some Linux distros ship ancient hamlib versions. I have good luck with 3.1 and later, although I have had to build them from scratch on both Ubuntu and Raspbian to get the latest version.
  9. AD7GR

    AD7GR Ham Member QRZ Page

    Good grief... your right... I was on the wrong tab. I tried the Hamlib tab but still no go, I get hamlib_init: I/O error

    This Mint 18.3 version is the latest and I've updated all that has been recommended. I;m guessing that it's the latest hamlib but don't know.
  10. KK5JY

    KK5JY Ham Member QRZ Page

    This post seems to describe how to find the version number of any package on your system:

    I'm not sure about that one. It sounds like one of the settings isn't quite right. Any chance you could post a pic of your fldigi configuration?

Share This Page