Linux and Yaesu CAT control.

Discussion in 'Computers, Hardware, and Operating Systems' started by VE3GZB, Jul 6, 2020.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-3
ad: Left-2
ad: FBNews-1
ad: Subscribe
  1. VE3GZB

    VE3GZB Ham Member QRZ Page

    Has anyone ever succeeded in figuring out how to make this combination work?

    I tried a distribution from KB1OIQ without success, I also tried the latest Mint Linux with the same dismal results.

    Audio transfers fine but there is no transmit capability nor any form of CAT control.

    The radio in question is an FT-991A and the computer is an Acer AspireOne D255 netbook which originally had some form of Windows 7. I bought it from evilBay for $35 with a blank hard drive.

    The size of this netbook is ideal for taking up north to a rented cabin with a wire antenna.

    73s
     
  2. PY2RAF

    PY2RAF XML Subscriber QRZ Page

    Hi

    I have successfully used WSJT-X with Red Hat Enterprise Linux 7 - The port is enumerated as /dev/ttyUSB0.

    Bu there's a catch - By default non-privileged users has no rights to access /dev/ttyUSB0.

    As the 'root' user, add your username to the dialout group - that will do the trick and then you will have access to the serial port. Try the below command:

    Code:
    # usermod -a -G dialout <your username>
    Best of luck;
    - RF.
     
  3. VE3GZB

    VE3GZB Ham Member QRZ Page

    I tried this command within Linux Mint, I had to put a "sudo" in front of it because it wouldn't accept it otherwise. Still there was no CAT control, no ability to toggle transmit even after this.

    I ran "lsusb" with and without the Yaesu plugged in and I did note changes as the computer identified "something" on the USB port. And I tried to correlate this information with what the software (WSJT-X, FLRig, FLDigi) saw.

    None of the software packages installed can even identify which port the Yaesu exists on. Within these software, when choosing a port, there seems to be about 70 choices many of which have "tty" in their identification. I tried as many as I could without success.

    What happened next, my ability to administer to system from my regular login, using my password, to run Synaptic or do any software changes, it was blocked. I suspected it had to do with the "usermod" command.

    I repeated the command then but changed it to # usermod -a G sudo <my username> and this restored my administrative ability but still didn't get the computer to be able to "talk" to the Yaesu.

    The distro from KB1OIQ seems to be less manageable, there's something in the readme files about how to address it but I'm apt to dump it if it looks too much like a lab experiment and not something I should take up on a northern trip to a cabin.

    I can control the Yaesu from a Macbook I have. That took some effort but it does work. But the Macbook isn't my first choice to take up north, I won't be totally alone and theft or loss remain a concern with such a device, hence the drive towards using an older cheaper Netbook.

    73s
     
  4. PY2RAF

    PY2RAF XML Subscriber QRZ Page

  5. W5UAA

    W5UAA Ham Member QRZ Page

    $sudo chmod 777 /dev/ttyUSB0

    or

    #chmod 777 /dev/ttyUSB0

    (always works, but you have to do this every time you boot your computer)
     
  6. VE3GZB

    VE3GZB Ham Member QRZ Page

    I installed Ubuntu 20.02 now and have installed FLRig, FLDigi and WSJTX.

    I tried "usermod -a -G dialout <your username>" and rebooted, with no success from FLRig.

    I tried "sudo chmod 777 /dev/ttyUSB0" with no success.

    I tried selecting any of a variety of TTY port choices and FLRig always returns this same answer:

    "Transceiver not responding.
    Check serial (COM) port connection.
    Open menu Config/Setup/Transceiver
    Press 'Ser Port' button, reselect port
    Press 'Init' button."

    I follow these instructions and nothing ever responds. I see the radio is set to 14.074. FLRig reports 14.070.

    I know the radio and cable work. I can make it all work with Windows 10 desktop or a Macbook, same hardware, same radio.

    73s
     
  7. VE3GZB

    VE3GZB Ham Member QRZ Page

    It's sort of working now all by itself. It took several reboots, cycling power on everything.

    FLRig still doesn't work. I know on my Windows 10 box and my Macbook that FLRig is a necessity when talking to Yaesu radios.

    On the Ubuntu 20.02 netbook I'm able to get both WSJT-X and FLDigi to work without FLRig. But like I said, there was some measure of power cycling/rebooting and a certain amount of cursing involved. Maybe the cursing solved it, Hi hi.

    73s
     
    PY2RAF likes this.
  8. W5UAA

    W5UAA Ham Member QRZ Page

    Yes, I've experienced Ubuntu and its branches (such as Mint) have many of the drivers/codecs associated with ham radio. No need to try to load any of them.

    $ dmesg | grep -w "USB*"

    will show you what's been recognized. For example, I connected an MFJ TNC-X via a USB port on Mint and the above command has:

    [ 1210.722597] usb 1-7: new full-speed USB device number 2 using xhci_hcd
    [ 1210.876415] usb 1-7: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
    [ 1210.876420] usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 1210.876423] usb 1-7: Product: FT232R USB UART
    [ 1211.111369] usbserial: USB Serial support registered for generic
    [ 1211.123524] usbserial: USB Serial support registered for FTDI USB Serial Device
    [ 1211.123583] ftdi_sio 1-7:1.0: FTDI USB Serial Device converter detected
    [ 1211.124516] usb 1-7: FTDI USB Serial Device converter now attached to ttyUSB0

    ...this in it. (1210 seconds after boot up, it connected--that's when I plugged the USB cable in...)

    This tells me the TNC-X is recognized and is functioning on /dev/ttyUSB0.

    The above command should give you the necessary info for future reference. If it's not working, you should be able to determine at least which ttyUSB* it's trying to connect to. Then,

    $ sudo chmod 777 /dev/ttyUSB*

    or

    # chmod 777 /dev/ttyUSB*

    will open up the permissions to allow anyone/anything to use that USB port. THEN fire up FLRig and tell it to attach to that USB number (/dev/ttyUSB*) and it should work. Then tell FLDigi to use FLRig.

    This works every time for me. Last time I did this was a few months ago.
     
    VE3GZB likes this.
  9. W4EAE

    W4EAE Premium Subscriber QRZ Page

    Using 777 privileges for this purpose is like opening a window with a hammer.

    644 would be my first try, and 666 my second--but never 777 outside of the home directory.
     
  10. W5UAA

    W5UAA Ham Member QRZ Page

    I don't disagree. But how many Icom, Yaesu and Kenwood radios have you heard of that've been taken over by malware? It might become an issue in the future. But I don't think it's anything to worry about now.
     
    AC0GT likes this.

Share This Page