Linux and Kenwood software for the TH-D74 HT

Discussion in 'Computers, Hardware, and Operating Systems' started by KI4POT, Sep 17, 2021.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-2
ad: L-Geochron
ad: Left-3
ad: HRDLLC-2
ad: MessiPaoloni-1
ad: abrind-2
  1. KI4POT

    KI4POT Ham Member QRZ Page

    I recently returned to Linux as my desktop OS. I've sorted out all the functions I need except one, the Memory Control Program, MCP-D74, for my D74. I tried Wine, but the MCP needs .Net and installing .Net under Wine doesn't seem to work. I then installed VirtualBox and Windows 10, which works, but apparently the VM isn't seeing the radio connected to the USB port. I've enabled access to USB and serial ports, but the app still doesn't see a radio connected.

    Any suggestions?

    Chris
     
  2. KC4WEB

    KC4WEB XML Subscriber QRZ Page

    Hi Chris. I don't have an answer to your question. However, I was curious which Linux distribution you are using?

    I use Ubuntu 20.04.3 LTS on my desktop and Raspbian on my Raspberry PI. I enjoy Linux but Windows remains my daily driver as it supports several applications that don't run natively on Linux.

    KC4WEB
     
  3. W5UAA

    W5UAA Ham Member QRZ Page

    Wine Is Not an Emulator. (a recursive acronym.)

    Well, it looks like you've found and fixed the usual problem associated with using a USB port through VirtualBox, so that's no longer the issue.

    The only thing left that's not intuitive by any means, and I've learned multiple times over the past several years, is maybe your computer is not providing enough USB power to your radio.

    Try a "powered" USB hub--one that comes with a 5 volt 2 amp wall wart.

    This has fixed many "why doesn't my computer see the USB port my radio's on?" problems. (Not all, but most.)
     
  4. KI4POT

    KI4POT Ham Member QRZ Page

    I use the same distribution here.

    I used Linux as my desktop OS exclusively back in the late 90s and early 2000s, but went back to Windows with Win2k. I'v been on Windows until just recently because my computer is getting old and I wanted to see if I could eke out a little more life. Linux "fixed" all my performance issues and aside from the Kenwood software one, I've found alternatives for everything I do.

    Chris
     
  5. KI4POT

    KI4POT Ham Member QRZ Page

    The same hardware running Win10 had no problem with the radio. I really think the issue is that Virtualbox isn't getting proper access to the ports, but I'm not sure where exactly the problem exists. The ports are enabled in the VirtualBox config and USB ports are evident in the virtual OS control panel. I know Linux can use those ports directly because I can manage my other HT using Chirp (which doesn't support the D74, btw).

    It just occurred to me I should try connecting a "normal" device like a USB stick to make sure the issue isn't specific to the radio.

    Chris
     
  6. W5UAA

    W5UAA Ham Member QRZ Page

    Yes, if a thumb drive doesn't work either then there's probably a conflict between your native OS and Virtualbox. Maybe nothing more than the permission or group assigned to /dev/ttyUSBx .

    Edit: might even be as simple as adding your user name to the dialout group since it's your username instantiating VirtualBox.

    $ sudo usermod -a -G dialout <username>

     
    Last edited: Sep 17, 2021
    WF9Q likes this.
  7. WF9Q

    WF9Q XML Subscriber QRZ Page

    Not what you want to hear, however its from experience.

    Run a windows box with its own keyboard, mouse and monitor to the right of you. Then at your work position have your Ubuntu machine with keyboard, monitor and mouse.

    Some win stuff is 100% perfect fit for virtual box, others are not. When it comes to USB, special video cards and other not so common devices its best to keep them separate.

    If you go that way and need to swap files you have many options that make it painless to cross platforms.

    Also keep in mind MS is not the same company they were back in the days of DOS. I will leave it at that.
     
  8. KI4POT

    KI4POT Ham Member QRZ Page

    I did that some time ago for another purpose.


    If I have to go the route of another PC, I'll just put the software on my wife's laptop. For how often I use this particular piece of software, it won't interfere with her use. It's literally the only thing left to making a 100% cutover to Linux.

    That said, I've run plenty of VMs in VMWare and such and never had issues getting to the USB ports. I might try VMWare Player.

    Chris
     
  9. WF9Q

    WF9Q XML Subscriber QRZ Page

    I have been buying Dell 3500 workstations on eBay for $150 SHIPPED and Win 10 pro installed.

    Those metal box workstations are even the best to use in the shack. I physically bond the case to the antenna ground rod that is at the coax exit/entrance point along with an Alpha Delta spark gap that is bonded to the 2 rods for the electrical service. It kills so much of the RFI hash, that is something a laptop will always have a problem with. You can verify this with a waterfall display if you have something like a IC-7300.

    Ubuntu runs very well on the Dell 3500's you can even install a SSD in those. I even pulled our old Dell Poweredge server( it takes a 2 wheel cart to move it) out of storage and run it headless with Ubuntu server and it is still has plenty of life in it ( new in 2007!). Old and good hardware is cheap. If you upgrade to SSD you can make those into Win boxes and still have fair performance with light weight software.
     
    Last edited: Sep 17, 2021
  10. KI4POT

    KI4POT Ham Member QRZ Page

    It's not the cost. I simply do not want another computer. Not counting my work laptop, I have 7 in this house to maintain. Of the 3 that are "mine", two run Linux (desktop and server), the other is a Chromebook. The computer in question isn't in my shack, but on a completely different floor. Also, it's not a laptop, but a"metal box" computer (built by me, but still a traditional tower). If I can't get this working, I'll just put the software on my wife's laptop. She won't care and the once or twice a year I need it won't interfere with her in any way. That's more desirable than adding yet another machine to manage.

    I tested a USB memory stick. It wasn't visible either. I ran VirtualBox as root, no change. I confirmed my userID was in the dialout group, it is. Next test will be with VMWare Player.

    Chris
     

Share This Page