Kenwood TS870 no respond TX..RX ok..

Discussion in 'Radio Circuits, Repair & Performance' started by YB4FIK, Aug 23, 2020.

Tags:
ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: L-MFJ
ad: Subscribe
ad: abrind-2
ad: Left-2
  1. YB4FIK

    YB4FIK Ham Member QRZ Page

    Haloo all, i have problem with my ts870 radio, it's doesn't want to transmit, tx doesn't respond, rx/receive is ok, when it is turned on and press the ptt for transmitting, the on air light doesn't turn on, I tried press the send button..same.. not active, can anyone help me to solve this problem?

    thank you

    Dony de YB4FIK
     
  2. W4FBI

    W4FBI Ham Member QRZ Page

    I had one that did that. Turned out to be bad (main) microprocessor.

    I assume you have tried a full 'reset'.

    Had to sell mine for parts...
     
  3. YB4FIK

    YB4FIK Ham Member QRZ Page

    Hi OM Alan, thanks for your response, is there no solution to solve the problem?,
    This problem arises because I haven't used this radio..maybe for more than 1 month
     
  4. VE3CLG

    VE3CLG Ham Member QRZ Page

    Reset the radio. look at the menu 27 save it at OFF this menu if it is ON then you are not be able to tx.
    press power and A-B at the same time to reset radio
    hope that will work
     
  5. KA5IPF

    KA5IPF Ham Member QRZ Page

    Not going into TX is a sign the PTT line is pulled low when powered up. It can be as simple as the PTT bar pushed on an MC-60 or some other ACCY shorting the PTT line. Remove ALL connections to the radio except the power cord then power up while holding A=B pushed. It should come up at 14.000.0 MHz USB mode. If so push the Send button. If it did not go into TX mode (red light) check Pin 2 of the Mic jack. It should be ~5v, if not the PTT line is being held low. Usually a shorted/leaky bypass cap on the line.
     
  6. YB4FIK

    YB4FIK Ham Member QRZ Page

    The problem has been resolved, I have put the radio in the box and I will send it to the technician, suddenly I want to try again, I turn it on and go back to normal, without touching any menu, maybe just stuck in a program that requires removing the DC cable.
    Thank you for all feedback, greetings from YB4FIK, Dony
     

    Attached Files:

    WA9UAA likes this.
  7. VE3CLG

    VE3CLG Ham Member QRZ Page

    I never had that problem.nice your radio is working again.
     

Share This Page