Kenwood TS-930 SAT multiple problems

Discussion in 'Radio Circuits, Repair & Performance' started by KM4YTW, May 5, 2020.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: L-MFJ
ad: Left-3
ad: Left-2
ad: Subscribe
  1. KM4YTW

    KM4YTW Ham Member QRZ Page

    Does anyone have a schematic of the signal board ? I have the componet drawing but not the schematic of the board. Thanks
     
  2. G4COE

    G4COE Ham Member QRZ Page

    We need be careful with the signal board, there are different versions, the first four numbers of the serial number are needed as I understand I refer to TS930S, the SAT version may well be the same, I can't be sure here.

    Dave
     
  3. KM4YTW

    KM4YTW Ham Member QRZ Page

    I wasn't aware of that. Mine is a sat with serial number of 4030069. The next impossibility is finding a schematic for it. Reason I need it is I have no TV voltage. Thanks.
     
  4. G3YRO

    G3YRO Ham Member QRZ Page

    It's almost certainly your Digital Board . . . just put wires through all the holes that go from one side to the other . . . and re-solder everything else.

    It's laborious . . . but quite straightforward . . . and doesn't cost anything !

    (even if the fault wasn't on that board, you would have to do this in the future anyway)

    I've just remembered one important thing . . . my rig came with a spare OLD digital board that had been replaced. As an IC had failed on the board in the rig, I set about repairing the soldering on the old board.

    However, when I removed the solder from some of the tracks, I found the copper underneath had kind of oxidized, so wouldn't take a solder joint until you scraped it clean. I then realized that simply re-soldering with leaded solder wouldn't work - I had to do this on EVERY connection! (so I gave up and fixed the newer board, which didn't have this problem . . . it just needed a 15 pence IC replacing !)

    So you need to check yours . . .

    Roger G3YRO
     
    Last edited: May 20, 2020
  5. KM4YTW

    KM4YTW Ham Member QRZ Page

    Thanks Rodger, i read your thread . Very interesting . Yeah ill rework that digital board very carefully and see if that helps. I couldnt see on the schematic where the digital board had anything to do with transmit voltage. I may be wrong.
     
  6. KA5IPF

    KA5IPF Ham Member QRZ Page

  7. KA5IPF

    KA5IPF Ham Member QRZ Page

    The Antenna tuner was an option. Most came with it. That's the difference between a "S" and a "SAT". Same for TS440, TS450, TS850, TS940. The logo on the front panel didn't change but the SN tag did.
     
  8. KM4YTW

    KM4YTW Ham Member QRZ Page

    Thank you Cliff. Ill check that out !
     
  9. KM4YTW

    KM4YTW Ham Member QRZ Page

    Confusion, im about half way thru resoldering the digital board but was checking the signal board and the schematics dont match up. My radio matches the overall schematic . Does anyone know which is right. The signal schematic shows 18 volt coming in on connector 5 , the over all schematic does not. I still done have the 16v tv voltage. Screenshot_20200521-145431.jpg Screenshot_20200521-145415.jpg Screenshot_20200521-145431.jpg Screenshot_20200521-145415.jpg 20200521_141314.jpg
     
  10. KM4YTW

    KM4YTW Ham Member QRZ Page

    Another question , on my digital board , connector1 pin 3 i have 8volts, the drawing shows i should have 10.7 volts . Is thjs a problem ?
     

Share This Page