Kenwood TS-590SG is not recognised by PC using USB cable

Discussion in 'General Technical Questions and Answers' started by VE6LXK, Mar 24, 2020.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Left-2
ad: L-MFJ
ad: Subscribe
ad: l-BCInc
  1. VE6LXK

    VE6LXK Ham Member QRZ Page

    I'm hooking up my Kenwood TS590SG to my windows 10 PC and have downloaded the Virtual Com Port Driver CP210X and am not having any response after unzipped and expanded and installed please advise thanks
     
  2. W1FBV

    W1FBV Ham Member QRZ Page

    Try unplugging the cable at the computer and then plug it back in. (That is about the extent of my technical skills.)
     
  3. SA4MDN

    SA4MDN Ham Member QRZ Page

    install com port drivers before plugging in radio, it can mess things up if the radio is plugged in when installing the drivers, if you plugged radio in after installing the drivers check your com port settings match the settings in the radio, ie, baud speed etc.
     
  4. VE6LXK

    VE6LXK Ham Member QRZ Page

    Thanks for the reply I tried different things like that it seems the Virtual Com Port Driver doesn't show up in Device Manager I'm hoping somebody else dealt with this issue and has the resolve
     
  5. KA9JLM

    KA9JLM Ham Member QRZ Page

    Run the driver installation as "Administrator" before connecting the radio.

    Do not let Win 10 find/install the wrong drivers automatically.
     
  6. W1BR

    W1BR Premium Subscriber QRZ Page

  7. KB0MNM

    KB0MNM Ham Member QRZ Page

    Experience tells me that it is sometimes necessary to delete drivers and re-install them. Of course, you may wish to carefully examine the system "Device Manager" for the names of these files and make back-ups before proceeding to delete them. The hardware 'Device Manager' has also been described as "Device Mangler" because it is possible to do more harm than good with it. A 'back-up' ( older copy ) copy of your operating system would not have the recent USB changes, yet may also be missing a recent 'security update'. When economically possible, use an external USB hard or solid state drive (SSD) to ensure that you can recover from problems such as folks describe ( KA9JLM did a good job of explaining what the root cause may be ).
     
  8. VE6LXK

    VE6LXK Ham Member QRZ Page

    Thanks I've tried "Run as Administrator" and still no change. I'm even trying to use a PC running Windows 7 and am having the same results.
     
  9. VE6LXK

    VE6LXK Ham Member QRZ Page

  10. AA3EE

    AA3EE Ham Member QRZ Page

    If it doesn't work on 2 different computers, I'd suspect the cable. I believe some cheap "charger" cables have only the power pair and do not include the data pair.
     

Share This Page