Kenwood TS-570S

Discussion in 'General Technical Questions and Answers' started by RAQUQIVI, Dec 11, 2019.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: MessiPaoloni-1
ad: Left-3
ad: Left-2
ad: L-MFJ
  1. RAQUQIVI

    RAQUQIVI QRZ Member

    Hello.
    I need to remove the Front board on my TS-570S.I have 3 push buttons that need cleaning/replacing.
    I cant get the VFO part to release from the board.
    Thank you.
     
  2. KA5IPF

    KA5IPF Ham Member QRZ Page

    Take the nut off behind the main knob.
     
  3. KF5KWO

    KF5KWO Ham Member QRZ Page

    I did this same thing back in September. Click on the link for a video from Ivan, PY1YB, which dealt with replacing the glass on the front panel, but he also had a detailed depiction of removing the top and bottom covers in order to remove the front panel:

    After removing the front panel, I saw that the nut securing the tuning shaft to the board was a loose, so therefore the shaft was slightly wobbly, meaning that turning the knob felt _very_ wobbly. I tightened the nut, put the knob on to check it (it was good), then put it all back together again.

    These two threads were helpful as well:

    https://groups.yahoo.com/neo/groups/TS-570/conversations/topics/7093
    https://forums.qrz.com/index.php?threads/help-with-ts-570-encoder-problem.498101/

    Good luck, hope it works out. I had never done it before, and was able to fix my issue just fine. Hope your button issue is easily remedied.

    73 de Jeff, KF5KWO
    Helotes, TX
     

Share This Page

ad: w5yi