Kenwood TS-570D transmit/tune problem

Discussion in 'Radio Circuits, Repair & Performance' started by KM4MK, Mar 5, 2017.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: Left-3
ad: MessiPaoloni-1
ad: Subscribe
ad: L-MFJ
  1. KM4MK

    KM4MK XML Subscriber QRZ Page

    Hi.

    The radio club at my local MakerSpace has a donated TS-570D. It was working fine when we first started using it.

    Last fall, it would sometimes "lose its tune" (SWR would suddenly jump) in mid-transmit, and in one case the unit spontaneously powered down. In fact, that was the last time it was used, around last November or so.

    We recently moved the entire rig, and I am in the process of getting the new system and antenna up and running. Here is a description of the current behavior, in a nutshell. I have duplicated this repeatedly. To narrow down the issue I removed both the external LDG tuner as well as the antenna - now using a rated 50 Ohm load.

    1) When in CW mode, it will not transmit. Pressing the SEND button does nothing. Stays receiving.
    2) When in SSB mode, it will not transmit. Pressing the PTT on the mike does nothing. Stays receiving.
    3) When holding the AT TUNE button to tune, it appears to tune ... and stays stuck in TX mode! Talking into the mike is continually transmitted, and changing the power setting changes the output power, and the SWR seems to read an appropriate value. There seems to be no way out of this stuck TX mode, except to cycle the power.

    It seems like the transmitter is likely working, and the issue is some aspect of the control circuitry.

    I found a copy of the service manual. While I am not afraid of attempting repairs, I am not an expert on radio/RF stuff. But I am a EE, and I can find my way around a schematic.

    Any advice is appreciated.
     
  2. WA9SVD

    WA9SVD Ham Member QRZ Page

    I'd first check that your power supply is adequate. (The TS-570D can require as much as 22 Amperes on CW key-down transmit.) Then I'd carefully step through the menus to see if something got scrambled. As a last resort, I'd document the menu settings you have and then, and only then, do a full reset
     
  3. KG4IKT

    KG4IKT Ham Member QRZ Page

    I'm having the same problems, and also when attempting to enter a freq via keypad, it just beeps, another is it won't add to memory or switch V/M, but it still beeps.
    Do you have an update on yours?
    I'm about to send it to avsl.net to get an estimate.
     
  4. N9LTV

    N9LTV Ham Member QRZ Page

     
  5. N9LTV

    N9LTV Ham Member QRZ Page

    Just curious....did you ever figure out the problem? My radio just started doing the exact same thing.
     
  6. WA4BCS

    WA4BCS XML Subscriber QRZ Page

    Try changing the internal battery.
     
  7. WA9SVD

    WA9SVD Ham Member QRZ Page


    Not sure there is something else involved. My TS-570SG (and a derelict estate sale TS-570SG) each have not experienced battery failure in over 10 years. I know it's about time for a transplant, but they still each function perfectly, including all memory and menu options. Even my TS-680s from 1992 still retains memory, although it does NEED a battery replacement soon.
     
  8. KG4IKT

    KG4IKT Ham Member QRZ Page

    I sent my TS570 to the Kenwood Service Center in Virginia Beach. They called to say it was "beyond economical repair". So I'll probably order a TS-590sg.​
     
  9. KG9H

    KG9H Ham Member QRZ Page

    Very odd, mine is doing the exact same thing.... Any one have a fix for this? Don't think I will send it in as the other fella stated not repairable. KG9H
     
  10. KG9H

    KG9H Ham Member QRZ Page

    Hmmm my old battery was at 3.0V, I replaced it with a new one at 3.3V, still not solved!
     

Share This Page