iMac snoozing when it shouldn't

Discussion in 'OS: Mac OS' started by K7GQ, Jul 22, 2020.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: Subscribe
ad: FBNews-1
ad: L-MFJ
ad: Left-3
  1. K7GQ

    K7GQ Subscriber QRZ Page

    I replaced a 2009 iMac with a 2017 iMac recently, both with High Sierra, and am now finding it impossible to simply let WSJT-X run unattended to provide reception reports to PSKreporter. Invariably, after some 15 minutes or more, WSJT-X stops decoding.

    The Energy Saver panel is checked for:
    -- Prevent computer from sleeping automatically when display is off
    -- put hard disks to sleep when possible
    -- wake for network access

    I have installed the utility AntiSleep which was unable to stop this snoozing.

    pmset -g | grep standby (shows)
    standby 0
    standbydelay 10800

    suggesting that the computer isn't going into standby mode.

    I'm now wondering if the system is putting the USB ports to sleep.

    Ideas or solutions gratefully accepted!

    Harry
     
  2. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Is AppNap enabled for WSJT-X? I'm not sure whether WSJT-X is subject to AppNap, and I'm at work right now so I can't check, but that may be one reason.
     
  3. WF7A

    WF7A Subscriber QRZ Page

    There are a handful of programs that come to mind to keep your Mac from sleeping: Caffeine (a freebie, but no longer supported IIRC), Amphetamine, KeepingYouAwake, and Anti Sleep. Check 'em out.
     
    K3DCW likes this.
  4. K7GQ

    K7GQ Subscriber QRZ Page

    I ran WSJT-X for several hours with the Activity Monitor running - the system (or App) snoozed pretty quickly. The Energy panel showed for WSJT-X

    -- App Nap NO
    -- Preventing Sleep YES

    Thanks, I've tried Anti Sleep without success.
     
  5. N0TZU

    N0TZU Platinum Subscriber Platinum Subscriber QRZ Page

    You might try setting the display turn off time to "never" as a workaround.

    Also, enabling Power Nap might help.
     
  6. K7GQ

    K7GQ Subscriber QRZ Page

    Anti Sleep didn't work but Amphetamine did - thanks for the reference.
     
    WF7A and K3DCW like this.
  7. K7GQ

    K7GQ Subscriber QRZ Page

    Well, I mis-spoke. Amphetamine is being ignored by my machine in an extended test. Still unable to let WSJT-X run unattended with the system snoozing.
     
  8. WF7A

    WF7A Subscriber QRZ Page

    How about entering this in Terminal:

    sudo systemsetup -setcomputersleep Never
     
  9. KJ4VTH

    KJ4VTH Ham Member QRZ Page

  10. K7GQ

    K7GQ Subscriber QRZ Page

    Thanks but it's already set to "Never"
     

Share This Page