ICOM USB drivers?

Discussion in 'Computers, Hardware, and Operating Systems' started by K9FV, Nov 18, 2019.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: Left-3
ad: L-MFJ
ad: Subscribe
ad: MessiPaoloni-1
  1. K9FV

    K9FV Ham Member QRZ Page

    Hello all, I've just ordered an IC-7610 and read USB driver must be downloaded for the computer connection. The ONLY drivers I found on ICOM site are for Win10. Is it possible to connect the 7610 USB to a linux computer?

    Thanks for any info,

    73 de Ken H> K9FV
     
  2. KA0HCP

    KA0HCP XML Subscriber QRZ Page

  3. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

  4. K9FV

    K9FV Ham Member QRZ Page

    Thanks ya'll, I had found the ICOM drivers page but as mentioned those are for Windoz. I was hoping the driver might be in my current Linux OS. I'm using Mint, ver 19, and will install the new 19.2 Tina. My kernel is 4.14..... something so I should be good to go.

    As long as the driver is included in the OS there should be no reason to do a manual installation - correct?
     
  5. W5UAA

    W5UAA Ham Member QRZ Page

    I haven't looked for a couple of months, but the last time I tried to connect an Icom to Linux, I came across an obscure driver using XML for Linux (I forget where), but it only did the very basics and it was a pain to get it to work. I remember only being able to change frequency and a couple other settings inside CQRlog and that was it. I think I was only able to get the basics to work under an Ubuntu branch of Linux. Couldn't do anything under Fedora. I was never able to find an audio codec for Linux that works with Icom. Heck, I can't even find what standard Icom uses for audio in/out their USB port. I gave up. I have a Win7 machine controlling my IC-7410 now. I tried to make Linux work, but I just couldn't and gave up.

    Good luck and post successful results, if you find them. I'd like to go back to Linux. I'm sticking to Win7 until I no longer have hardware that supports it, then I'll make do with what ever I can with Linux in the future.
     
    K9FV likes this.
  6. K9FV

    K9FV Ham Member QRZ Page

    Drivers is something I never even considered when I purchased the 7610, but I expect the FTdx-101D would have had the same problems. Looking some more at the silabs link for the Yaesu drivers, and it looks like ICOM and Yaesu might be using the same CP-210x USB to UART chip. If so, then that shouldn't be a problem. Be nice if ICOM & Yaesu would just say that's what needed. I've been using those drivers and chips in different projects with no problem with Linux.

    Guy, you said you were not able to get the ICOM to connect to a Linux computer, and were not able to find the chip used? If we could find the schematic for the ICOM should (well, might) be able to determine which chip is used.

    Thanks for all the info.
     
  7. W5UAA

    W5UAA Ham Member QRZ Page

    I seem to remember doing a "dmesg" and seeing CP210X being loaded automatically under udev. Hotplug USB device, meaning the driver was available in the OS. It was the audio codec that I was not able to find. Simple Icom frames could be sent to/from the icom for basic control (change frequency/mode, but that was about it), but no audio and I couldn't get the darn radio to switch to TX mode.
     
  8. W5UAA

    W5UAA Ham Member QRZ Page

    Ya, here's a guy that says it works perfectly now (June 2018)

    https://linuxer.eu/icom-ic-7300-and-ubuntu-18-04/

    Yes, I got the same dmesg "cp210x" found, but I don't remember a PCM2901 Audio Codec. I was trying to connect to CQRlog and WSJT-X, so maybe that's where my problem was. This guy is just using basic linux commands and says it works. So I guess the CQRLog folks aren't up to speed yet or I was experiencing some kind of conflict with WSJT-X.
     
    Last edited: Nov 19, 2019
  9. K9FV

    K9FV Ham Member QRZ Page

    Thank you for the link, maybe I'll be able to get it working like he did. When I upgraded from 18 to 19 Mint I had a bit of issue getting the audio working correctly again. I really do like Linux, but there are certainly more issues getting radio stuff working with Linux than with Windoz.
     
  10. K9FV

    K9FV Ham Member QRZ Page

    A follow up on getting the 7610 to operate on Linux using the internal sound card. Following the advice of G4LNA and W5UAA I seem to have Fldigi and WSJTX both using the internal sound card.

    First I had to add "dialout" and "audio" to the Linux system.

    The using the drivers for the CP2102 chipset it seemed to go pretty good.

    WSJTX worked pretty good with CAT control using the USB port "/dev/ttyUSB0" and was easy to setup with CAT control.

    Fldigi used the same "/dev/ttyUSB0" port. Under "rig control" the "RigCAT" tab was selected, the rig description file is required to be loaded. I was never able to find ICOM's xml file for the 7610, but there are a couple folks who have mod'd the 7600 file to work with the 7610. Loading that file and selecting /dev/ttyUSB0, then checking the "Use RigCAT", "Commands are echoed", and "CAT command for PTT" buttons got everything working where the CAT controls seem to be working good. The sound card is "USB Audio CODEC: -(hw:1.0)" or at least that's what seems to be working for me. If a link is needed for the mod'd xml file for the 7610 just holler.

    Good luck to all, and thank ya'll for the guidance.

    73 de Ken H> K9FV
     

Share This Page