Icom RS-BA1 IC-7300

Discussion in 'Amateur Radio Software' started by KC9SWV, Jun 3, 2016.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: abrind-2
ad: Left-3
ad: QSOToday-1
ad: Subscribe
ad: L-MFJ
  1. KA1YBS

    KA1YBS XML Subscriber QRZ Page

    Anyone get HRD to work with RS-BA1 at the same time over Ethernet?
     
  2. VE3PS

    VE3PS Ham Member QRZ Page

    I know this is a very old thread but, although I've had the software for quite some time, I am just now attempting to remote my 7300 and I am getting exactly the same error. I am running the latest Win10 Pro OS version on both my base station PC/server and my remote PC. I expect I am misinterpreting something and there is a simple configuration that I have wrong.

    I have the radio connected via a USB cable to the base station PC and RA-BA1 installed on both PCs. I thought I had everything configured as directed but, although the base station PC connects to the radio, I have no errors indicated, and I can control the radio via the base station PC, when I attempt to control the radio from the remote PC (on the same Wi-Fi home network), I get that "Cannot open COM Port" error.

    When I run the Remote Utility on the remote PC, and attempt to connect, it connects but, when I run the Remote Control on that remote PC, the Cannot open COM port error occurs.

    Any suggestions would be much appreciated. Thank you
     
  3. NM3P

    NM3P Ham Member QRZ Page

    On the Remote Control window, go to 'Option', and 'Connect Settings' and verify your com port, baud rate, and CI-V address.
    Mine are set like this...
    Com Port = 4 (yours may vary)
    Baud rate = 115200 (again, yours may vary)
    CI-V Address (radio) = 94 (Most 7300's should have this setting)
    Note: you should be able to see these first three on the Remote Utility window
    CI-V Address (RS-BA1) = E0

    I think one of the problems with this software is that while almost everyone eventually gets it working, nobody ever documents all the tinkering they did when they were finally able to make it work, so nobody is ever sure exactly what they did that resolved it.

    One other thing that took me a while was to make sure that the radio drivers are loaded on the server pc before a connection attempt. This normally means that you have to have power applied to the radio (says captain obvious), but also the radio had to be turned on at least once before the connection attempt. At least, that is how mine acts.

    73 & GL. You'll get it.
    John
     
  4. VE3PS

    VE3PS Ham Member QRZ Page


    John, thanks very much for the reply. My settings are similar to yours. I wholeheartedly agree with your comment about lack of documenting all the tinkering required to get this to work. I am trying to document whatever I am doing but I still have no solution. To wit:

    1) My initial problem was that I was always getting a Cannot Open COM Port error when I launched the Remote Control and clicked the Connect (Power On) button icon.
    2) I resolved that when I realized that the Remote Utility on either the server PC or remote PC can connect to the radio, but not both at the same time, and then I was able to remotely control the radio from either the server PC or the remote PC, but I had no audio on either PC (N.B., if I adjust the audio volume through either PC, the audio output on the radio did change accordingly).
    3) Just before receiving your reply, during my scrambling to find an answer, I noted that on the remote PC, under the Windows Settings Installed Apps list, there was a Windows USB driver from Silicon Labs - but that did not show up in the server PC, even though I could see all the appropriate 'devices' under Device Manager (Audio I/O, Multiport Serial Adapters, Ports, Sound et al Controllers) .
    4) Thinking that perhaps the Silicon Labs driver was improperly installed on the server PC, because it was not showing on the installed apps list, under Device Manager/Ports I uninstalled the driver, then unplugged the USB cable and reinstalled the driver.
    5) Now the driver is showing in the installed apps list i.e., Windows Driver Package - Silicon Laboratories Inc. (silabser) Ports...
    6) It did however change the virtual COM Port number from 4 to 3; so, on the remote PC, I changed the virtual COM Port to 3 to match the one on the server PC.

    Good, I thought, until I launched the Remote Control app, first on the server PC, and noted that I still had control but, as before, there was no audio. If I cannot get audio when controlling via the server PC, then I'm not going to get audio on the remote PC - and that remains the case.

    As it appears to be strictly an audio issue, may I ask what your audio device settings are on the server and remote PCs?

    I appreciate your efforts to assist.

    73... Paul
     
  5. NM3P

    NM3P Ham Member QRZ Page

    On the remote utility on both the server pc and the remote pc, I have 'Default Device' listed for both speakers and mic. I believe the audio is passed between the two using the virtual audio ICOM_VAUDIO-1 (all at 48Khz). So, if I connect from the server pc, or if I connect from the remote, either way I am hearing audio on the default audio device (and microphone). On the remote pc, for the network settings in the properties, I clicked on 'Recommended' and selected LAN as both machines are on the same lan. When I go remote, I reset that to 'Internet' and vpn into my home network.

    At one point, I did have to go into the sound control panel and adjust levels on the ICOM_VAUDIO, and I also had to adjust audio settings in the 7300 for acc/usb af output level, and also the usb mod level.

    Again, I don't have it all documented :)

    Edit: fyi, I am using Windows 7 for both server pc and remote (laptop)
     
    Last edited: Dec 2, 2020
  6. VE3PS

    VE3PS Ham Member QRZ Page

    Thanks for the follow-up John.

    I am running the same version of Win10 Pro on both computers. As you can see in the JPG file, I believe I have those settings configured the same as yours, and I have cranked the PC audio output all the way to 100%, for now at least.

    However, I do notice an anomaly, namely that the audio output devices bear different 'names' even though I have selected the same audio devices within the Remote Utility app on both PCs. That tells me something may be different between the installation on the server PC and on the remote PC, but which (if either) is correct?

    Could it be that a different version of the driver was somehow installed on each PC? I have no idea how that could happen, but...

    This is truly baffling!

    Thanks again... Paul
     

    Attached Files:

  7. VE3PS

    VE3PS Ham Member QRZ Page

    One more thing I notice, which may or may not mean anything, but do you understand the ICOM_VAUDIO-1 (I=2 O=2) on the server PC and ICOM_VAUDIO-1 (I=0 O=0) on the remote PC? I am presuming the I and O refer to Input and Output but, even if I am correct, why the difference (2 versus 0)?

    Perhaps incorrectly, but I keep focussing on the fact that even the server PC has no audio.

    Thanks... Paul
     
  8. NM3P

    NM3P Ham Member QRZ Page

    So just for kicks yesterday, I had my 7300 being remotely controlled by my laptop for most of the day. At the end of the day, I shut down the software, but left the two computers running overnight. Today, I could connect from the server pc, but not from the remote, I was getting the virtual serial port error. I shut down the software on both, rebooted the server pc, and then it came right up and worked. I made no config changes. Like I said, both are Windows 7. But I think that shows that there is something flaky in the remote utility on the server pc, at least on Windows 7.

    Edit: As to the I and O settings on icom_vaudio, I am not sure, but I think they relate to local resources. On my server pc, right now it says I=3, O=4, and on my remote pc is says I=0, O=1.
    It is probably documented somewhere, but off the top of my head, I don't know.

    FYI: Page 7-6 of the manual has a whole page on received audio.
     
    Last edited: Dec 3, 2020
  9. VE3PS

    VE3PS Ham Member QRZ Page

    That's not all that unusual in the Windows world! I believe PCs need to be rebooted from time to time to clean up left-over clutter that will sooner or later impacts apps.

    In my case, however, because I have yet to get it working fully and, therefore, I am not actually using it, my server PC gets shut down in between each of my scrambling efforts to resolve the problem - i.e., a number of times per day.

    Regarding the I and O settings, you have introduced another possible issue. If they relate to local resources, the fact that your I and your O 'resources' differ on each PC. I wonder if my problem could be that I and O are both the same on each PC (both are 2 on the server, and both are 0 on the remote). Would it not make sense that I and O should differ?

    I cannot tell you how much I appreciate your comments, as I have been struggling with this for weeks and I live in a rural area where they are a limited number of other 'hams', and only 1other has the 7300 and he has no interest in remoting it.

    Thanks again... Paul
     
  10. NM3P

    NM3P Ham Member QRZ Page

    I am not sure where I found this, but maybe it will help....
     

    Attached Files:

Share This Page