ad: Amateur-1

Icom RS-BA1 IC-7300

Discussion in 'Amateur Radio Software' started by KC9SWV, Jun 3, 2016.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Left-3
ad: Subscribe
ad: L-MFJ
ad: Left-2
  1. KC9SWV

    KC9SWV Ham Member QRZ Page

    Okay,

    Just got my new IC-7300 and I'm trying to get RS-BA1 setup and I can't figure out what I'm doing wrong. Here's a rundown of what I've done...basically I followed all the steps from the 43 minute video on Icom's website.

    *Install the Icom USB driver on both my desktop and laptop.
    *Install RS-BA1 on both my desktop and laptop.
    *Connect the 7300 to the desktop by USB.
    *Set USB CI-V to disconnected from Remote CI-V (allows higher than 19,200 baud).
    *Set USB CI-V to 115,200 baud to allow for waterfall.
    *Setup the desktop RS-BA1 Remote Utility as the server. It can connect locally to the 7300 successfully.
    *Tested the RS-BA1 Remote Control locally (without using Remote Utility). It works.
    *Tried testing RS-BA1 Remote Control locally by using Remote Utility. Doesn't work, unclear if it should.
    *Setup the RS-BA1 Remote Utility on the laptop to connect to the desktop. It does.
    *Tried to connect RS-BA1 Remote Control to Remote Utility on laptop. Doesn't work.
    *Tried it all over with 19,200 baud, with and without USB CI-V linked to Remote. Still doesn't work.
    *Setup port forwarding in my router and signed up for new DynDNS account.
    *Tried it all again through dynamic DNS instead of direct local IP. Still doesn't work.
    *Tried it all again at 115,200 and 19,200 from different laptop using Win7. My current laptop uses Win10.
    *Got tired of screwing with it and decided to get on the air and worry about the remote stuff later.

    The weird part is that it all connects like it should until I get to the point of connecting the Remote Control program to the Remote Utility program on my laptop (or desktop, but not sure if that would ever work). I even get audio from the radio remotely on the laptop like I should. I just can't control the radio!

    Any thoughts?
    Remote Software Settings:
    [​IMG]

    Base Software Settings:
    [​IMG]

    Radio Settings:
    [​IMG]
    [​IMG]
     

    Attached Files:

  2. KC9SWV

    KC9SWV Ham Member QRZ Page

    FYI, for anyone else having similar issues:

    I tried again on Windows 7 and it worked this time. All I did was remove and then reinstall the program...no idea why that would work when it didn't the first time.

    Having success with that, I tried setting the "Compatibility Mode" in Windows 10 to "Windows 7" for both the Remote Utility and Remote Control programs. Now they work! Weird...
     
  3. OV5P

    OV5P Ham Member QRZ Page

    Just did a setup also. What a nightmare. The 43 minutes video shows that the remote pc should select "remote" in the connection from "remote utility". 2 hours later i just tried on the remote to set it to USB and wham it worked. I cant see on your pictures if you did the same. The video shows to use "remote" in the drop box...but "USB" made my day on the remote pc.
     
  4. KC9SWV

    KC9SWV Ham Member QRZ Page

    Yup, can't use Remote. USB works sometimes. Course, I have a 7300 which isn't supported by any software yet, so have it set to the ID of a 7100 and the baud rate turned down to 19200. It almost works some of the time. I can't wait until WSJT-X and others support the 7300 natively because it's a real bummer when some new DX pops up and you try to call them and 17 seconds in to your transmission it drops out and gives a CAT error, which halts transmit.

    The really disappointing part is that the free W4MQ software for my old TS-480 worked great and was easy to setup. The free Kenwood software that came with the TS-480 worked well, too. The $100 Icom software doesn't work reliably at all and is terrible to setup and poorly translated. I mean come on, for the money you're charging, you can't even have someone at Icom America, who speaks English natively, read over your status messages and button labels and tell you what they should say?
     
  5. M1CTK

    M1CTK Ham Member QRZ Page

    I am just wondering why with the Remote Control program all options for changing to the 7300 selecting com port etc are greyed out...so of course all I get is a Cannot open COM port' error box when I load...using latest version 1.92

    the remote utility sees the radio no problem...

    Of course the 7300 is connected and on etc

    Any ideas anyone please
     
  6. KC9SWV

    KC9SWV Ham Member QRZ Page

    After you get the "Cannot open COM port" error, you have to click on the Connect button that's currently lit up to turn it gray again. Then you should be able to change those settings.
     
  7. M1CTK

    M1CTK Ham Member QRZ Page

    yes what a clutz, ok thanks but I am getting constant transmit when the program has loaded ??
     
  8. KC9SWV

    KC9SWV Ham Member QRZ Page

    Hmm...that's strange. I would check that VOX is off and also your settings for USB Key and USB TX in the 7300's menu. Maybe the program is taking DTR or RTS high and causing the transmit.
     
  9. M1CTK

    M1CTK Ham Member QRZ Page

    Thanks yes that was it, has to change to RTS for it to work, rgds and 73
     
  10. N0NSR

    N0NSR XML Subscriber QRZ Page

    I use the software with an IC-7100 and for some reason, sometimes when I start the software, it won't communicate. Nearly always, exiting the software, unplugging and replugging the usb cable that goes to the radio, then starting the software again will allow the software to work.
     

Share This Page