ICOM Rig Control problem w/ Windows 10 Laptop(s)

Discussion in 'Computers, Hardware, and Operating Systems' started by N4WDL, Oct 13, 2020.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-2
ad: Subscribe
ad: Left-3
ad: abrind-2
  1. N4WDL

    N4WDL Ham Member QRZ Page

    VERY STRANGE PROBLEM I've had ICOM CI-V connections running for years on different computers and different radios, but now I can't get it to work on either of 2 older Dell laptops running Windows 10. However it works fine with another Dell desktop also running Windows 10.

    The radio in this case is an ICOM 706MKIIG. I've tried a West Mountain Radio RIGblaster PLug & Play and another USB to serial CI-V adapter/cable. Both will work on the desktop PC but neither work on either of the 2 laptops. I've used the driver Windows installs for the USB devices as well as the West Mountain Radio drivers (I also have their latest utility for testing). All equipment (Power Supply, radio) is grounded together and to earth, tried laptop on and off battery.

    Windows sees the devices and all seems well. With the RIG blaster P&P and their utility it will activate PTT (the radio transmits), the rig control via CI-V just will not read frequency nor connect to apps like flrig or Ham Radio Deluxe. I can simply move the USB cable to the desktop and it works fine.

    It must be a Windows problem but I can't identify it. I've been in touch with WMR and exhausted their suggestions. So I'm turning to this community for ideas.

    Thanks,
    David Lindsey, N4WDL
    dlindsey2022@gmail.com
     
  2. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    you might try rs-ba1@groups.io
    theres been some discussion on ports not working after updates
    https://groups.io/g/rs-ba1/topic/wi...,0,0::recentpostdate/sticky,,,20,2,0,76405591

    Once in a while on the setup here, especially with arduino usb connections, I find the port is locked out, renumbered or reserved (to what I dont know). I end up using COM_Name_Arbiter_Setter.exe to free them up
    Hasnt happened to the rtlsdr or my 9100 yet.

    There might be a group.io for icom civ or your rig. worth taking a look
     
  3. N4WDL

    N4WDL Ham Member QRZ Page

    Thanks Robert. I’ll give that a try. ‍
     
    VE3CGA likes this.
  4. N4WDL

    N4WDL Ham Member QRZ Page

    Problem solved... Problem turned out to be with the radio. The 1/8" connector for the Remote CI-V connector did not have ground continuity. Added a jumper to ground... problem solved.
     

Share This Page