ICOM IC-7700 WSJT-X using RS-BA1 Version 2

Discussion in 'Computers, Hardware, and Operating Systems' started by W7MDB, Feb 1, 2019.

ad: L-HROutlet
ad: l-rl
ad: FBNews-1
ad: Subscribe
ad: Left-2
ad: L-MFJ
ad: Left-3
  1. W7MDB

    W7MDB Ham Member QRZ Page

    I am trying to get my WSJT-X software working over LAN to my IC-7700. The RS-BA1 software seems to work fine. I have the Remote Control software launched but not connected when I am attempting WSJT-X

    In WSJT

    In General -> Allow Tx frequency changes while transmitting -> checked
    Radio -> Rig -> Icom IC-7700
    Baud Rate -> 9600 (which is what my radio is set to - I tried different rates with no change in behavior
    Data Bits - Eight (also tried Default with no change in behavior)
    Stop Bits - One (also tried Default with no change in behavior)
    Handshake - None
    PTT Method - CAT
    Transmit Audio Source - Front/Mic
    Mode - Data/Pkt
    Split Operation - None

    Test CAT- Turns green when I test it.
    Test PTT - Causes the radio to enter into transmit mode. But then.. when I press it again
    to turn Test PTT Off, I get the message:


    Rig failure

    Hamlib error: Command rejected by the rig while setting PTT off

    Thanks for your help and 73,

    - Mitch

    Attached Files:

  2. W7MDB

    W7MDB Ham Member QRZ Page

    More data... I get a Hamlib error: Protocol Error while getting current frequency error when the radio is in SPLIT mode operation, but do not when the radio is not.
  3. W7MDB

    W7MDB Ham Member QRZ Page

    I got it working. I set WSJT-X to "Fake it" mode, which does not require a split (it sends the transmit frequency just before transmit). It seems that the bug is in the sending the split information to the PC. Moral - keep the radio out of split mode when doing digital modes with the IC-7700.

Share This Page

ad: M2Ant-1