ICOM 7600 wont power on.

Discussion in 'Radio Circuits, Repair & Performance' started by N9ZDZ, Aug 8, 2018.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-3
ad: MessiPaoloni-1
ad: l-assoc
ad: Left-2
ad: Subscribe
  1. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    no there's still something else wrong. but all the volts are correct now in that part of the circuit.
     
  2. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    Well it looks like IC-103 =HD6417751RBG240V on the logic board is getting really hot . So we might be at the end of road. soon as I hook up ribbon cable from j802 on the logic board to J604 on display board the IC states getting hot.
     
    Last edited: Aug 29, 2018
  3. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    any ideas on what to do next ?
     
  4. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    Looks like I am getting the 7600 back
     
  5. KA9JLM

    KA9JLM Ham Member QRZ Page

    Did you sell it or send it in for repair ?
     
  6. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    I traded it off but the guy said it had all ready been to icom and they told him it’s 1000 dollars to fix it so he wasn’t happy so we are trading back
     
  7. KA9JLM

    KA9JLM Ham Member QRZ Page

    Bummer. :(
     
    N9ZDZ likes this.
  8. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    I might order IC 103 and replace it
     
  9. KA9JLM

    KA9JLM Ham Member QRZ Page

    That is a nice radio, It may be worth it.

    Does that chip need to be programmed ?
     
  10. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    I have no clue but I will repost it in the mean time just to see what offers are out there/
     

Share This Page