ad: wmr-1

Icom 7410 and fldigi or wsjt-x? I am clueless. Help?

Discussion in 'Working Different Modes' started by NG9F, Sep 4, 2017.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Left-2
ad: Subscribe
ad: MessiPaoloni-1
ad: L-MFJ
  1. NG9F

    NG9F Premium Subscriber QRZ Page

    I have the rig connected to the radio with a USB cable, and yes I installed the drivers first. What is my next step? I have both fldigi and wsjt-x on the PC which runs Windows 10. I've tried reading through the help files but a lot of the information is tricky to interpret because I don't have a PhD in computer science. :)

    If you have any tips for starting to decode, or for setting up either software with the 7410, I am all ears. If you could just tell me what mode I should be starting with that would be a great help. I've set the menu items on the 7410 as so:

    38 - on
    39 - 50
    40 - USB
    41 - usb
    42 - 19200
    43 - 80
    44 - on
    45 - CI-V

    Any tips are most appreciated. If I should be looking at software other than fldigi or wsjt, let me know. I just want to get on the air with digital! I want DX!!!!
     
  2. KC3RN

    KC3RN Ham Member QRZ Page

    You seem to have your radio set up okay. Now the next step is to go into your software. On FLDigi, go to "Configure" - "Sound Card" and select "USB Audio CODEC" for both Capture and Playback. Then Hit "Save" and "Close". That will allow your radio to communicate with your computer.

    On WSJY-X, go to "File" - "Settings" - "Audio" and do the same thing (select USB Audio CODEC) for both Input and Output. Also, check what version of WSJT-X you're running. I would recommend you download v1.8.0-rc2. That's the latest version. That version has the latest updates for FT8, which is the hot mode right now.
     
  3. NS0S

    NS0S Ham Member QRZ Page

    Any luck? What was your setting for wsjt-x and for the 7410 if you got it working? Heck, what are you windows settings? I am lost too.
     
  4. W4NNF

    W4NNF XML Subscriber QRZ Page

    It would help to know where you are lost... Decoding? Transmitting? Rig control?

    The first step is selecting the proper sound card. If you have a rig with a built in sound card, or an interface with a built in sound card you MUST select that sound card in the software and NOT the PC's built in sound card.

    While this video concerns the IC7200 and fldigi, you may find it helpful with your rig and your software as well..


     
  5. NS0S

    NS0S Ham Member QRZ Page

    I have the correct sound card enabled. It isnt the problem.

    On every program(fldigi, wsjtx,etc) I use it will put the radio in transmit mode and lock up. It will not put any sound in the radio. On wsjtx it gives and error and says sound output error. Then I have to physically hit the transmit button on the radio for it to stop transmitting. I have tried various bauds. I have installed all the drivers. I have found more than one person with this same issue online but no one has put an answer. The radio will transmit but it will not put sound into the radio.

    On device manager on windows it will flash off and on and put an error next to the sound device. The computer can listen to the radio with no problems through USB.

    I have dealt with this for multiple days. At first the computer wouldn't even see the radio. I bought a powered USB and the now the computer can see the sound card and radio.

    It also seems like when the radio cat controls the the transmit all the sound function go haywire.

    Somehow today it all worked for a few moments. I left and came back 2 hours later. I changed nothing at all on the computer and it stopped working again. Here is a post with the same exact problem and they were on linux.

    http://permalink.gmane.org/gmane.comp.radio.linuxham/22819
     
  6. W4NNF

    W4NNF XML Subscriber QRZ Page


    The first thing to do is clear up the driver error you're getting on the interface's sound card. This may require not just reinstalling the driver, but deleting the old one (in Control Panel). As for the rig interface, that's a separate issue. Get the sound card sorted first.
     
  7. W5DXP

    W5DXP Ham Member QRZ Page

    I had a similar strange problem with my configuration. I have a desktop PC with a Sony TV for the display/monitor. For some crazy reason that I don't understand, the volume control on the TV remote control is in control of the audio output of my PC sound card into my IC-756PRO. If I mute the TV, "the radio will transmit but it will not put sound into the radio." I can control the PSK31 power output of my IC-756PRO using the volume control buttons on my Sony TV remote control. Could you possibly have the same problem?

    I don't understand how the PC knows what is happening with the TV remote volume control.
     
  8. KD4MOJ

    KD4MOJ Premium Subscriber QRZ Page

    Going from memory... but check the settings in the 7410 for USB data mode (turn on). In the SSB mode, hold down for 1 second to select the SSB data mode (USB-D).
    Then go into WSJT > Settings > Radio > Mode and turn OFF data. WSJT tries to control your data mode and sometimes switching it off when you need it on.

    On your settings above:

    40 DATA OFF MOD - MIC,ACC
    44 OFF

    Try the above and see what happens.

    ...DOUG
    KD4MOJ
     
  9. KD0YTE

    KD0YTE Premium Subscriber QRZ Page

    I have a 7410. There are a couple of things to be aware of. Press the mode button until you are in USB mode then press and hold the mode button to enable "USB-D" or usb data mode. if you don't do that the radio will transmit but will have no modulation. Secondly go into the menus and make sure usb is set as the source for data mode and mic is set for regular phone mode. Thirdly in the menus adjust usb mod level down to about 50 percent or even less then make sure your alc level on the meter is down to about 1/3rd the way between the brackets on the left side of the meter. In wsjt-x select the comport that the usb cable emulates. and make sure rig is set to icom 7410. last thing to be aware of is if the usb cable you are using is longer than about 3 ft you may have problems with the radio "dropping out" of device manager intermittently. Hope that helps. 73
     
  10. NS0S

    NS0S Ham Member QRZ Page

    I got it working. But, it is my secret. JUST KIDDING!

    Okay, this is going to be a PITA to explain.
    First, if your radio doesn't recognize the USB device without a powered USB hub then get a 3 foot cable and not a cheap one. That is why I had to use a powered USB. I got a shorter cable and it works perfect. The old cable was only 6 feet long. That was too much. I am guessing the chip in the radio is old and it couldn't keep up with today's standard for faster speeds. The radio is only 4 years old but the chip inside it is probably years old.

    Second, with your radio plugged into the computer delete the two audio devices(USB Audio Code PCM2301- if it says this it is BAD) and the silicon labs for the port stuff that shows up on the computer in device manager. Now unplug your radio.

    Third, go to "add and remove programs". Do you see Icom USB to Serial Ver B.? It is okay if you don't.

    Go through and delete every single driver you installed here. Anything that says Silicon Labs or Texas Instruments gets deleted. You might have 3 files that need to go depending on what you were trying to do. One of them will be in there. It is what is jacking this stuff up.

    After that did the icom file show back up in the programs list?

    If it didnt show up go download it from Icom again. Install it. Version 1.2. DO NOT INSTALL ANYTHING ELSE. It will take over the drivers and jack it all up. Now your audio files with say "USB Audio CODEC".

    Now, plug your radio back in. For WSJTX: COM Port(x), 19200, 8 Data, 1 Stop, None Handshake, blank on DTR and RTS, CAT for PTT, Data for Mode, None for Split. Test it! When transmitting make sure the output from the computer is turned down so you only see one bar on ALC on the radio.

    Radio settings:
    38-off
    39-50% but you can move it)
    40-Data off mode is Mic ACC(this is the mode for when you are using the microphone. You shouldn't be using data then.
    41-Data mode-USB
    42-CI-V 19200 works perfect. Just make sure your software is matching
    43-CV-V Address 80h
    44-leave it on. It makes it so if you adjust your dial physically your radio program will know
    45-USB-CI-V
     

Share This Page

ad: UR5CDX-1