Icom 706 mk2g problems

Discussion in 'Ham Radio Discussions' started by 9W2KNZ, Dec 15, 2017.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: MessiPaoloni-1
ad: Subscribe
ad: Left-2
ad: L-MFJ
  1. 9W2KNZ

    9W2KNZ Ham Member QRZ Page

    I had a problem with my 706 mk2g. When a few secon i switched on i heard a clicking sound and my radio become deaf and no power output. Now my radio when switched on the signal full on rx but no audio and cant tx. In a few second i'll can heard some signal and power output also ok. Do help me. Thanks in advance
     
  2. AG1W

    AG1W Ham Member QRZ Page

    Does it have an automatic tuner? It may have frozen up
     
  3. W4NNF

    W4NNF XML Subscriber QRZ Page

    Could be a tuner problem, yeah. Could be the T/R relay. Could be coax/connections. Could be a lot of things. Step one is to disconnect the rig from an external tuner and/or amplifier or anything else you're using external to the transceiver. Check the coax/connections. Try injecting a signal with a signal generator if you have one.
     
  4. 9W2KNZ

    9W2KNZ Ham Member QRZ Page

    ="AC1CX, post: 4489712, member: 846043"]Does it have an automatic tuner? It may have frozen up[/QUOTE]
    No. I'm not using any tuner because all my antennas matches with several freq
     
  5. 9W2KNZ

    9W2KNZ Ham Member QRZ Page

    I already disconnect all antennas while i'll switched on my radio a few second it be the same problem
     
  6. KC8VWM

    KC8VWM Ham Member QRZ Page

    You can try a factory reset.

    Hold [UP] & [DOWN] buttons while turning the radio on.
     
  7. US7IGN

    US7IGN Ham Member QRZ Page

    I had same issue http://www.us7ign.com/?p=457 and I solved it.
    You can check this point.
     
  8. KA0HCP

    KA0HCP XML Subscriber QRZ Page

    My MkIIg has about 250,000 road miles on it. Reception became intermittent an poor, signals had a ringing sound. Took radio apart, cleaned and reseated all connectors, ribbon cables, and wiggled all PCB's in mounts. Solved problem.
     
    AG1W likes this.
  9. KY5U

    KY5U Subscriber QRZ Page

    Possible steps: (Try step, if works stop. If not, do next step.)

    1, Verify power supply voltage (under load) even on a battery.
    2. Do the reset as suggested by KC8VWM
    3. Do the "clean connectors" suggested by KB4QAA
    4. It needs a visit to a repair shop or the more involved (but not the same problem) by US7IGN.
     
    KA0HCP likes this.
  10. 9W2KNZ

    9W2KNZ Ham Member QRZ Page

    Ya i know that is not that same problems with US7IGN my radio still can on but right now the signal become full and no audio
     

Share This Page

ad: KF7PMW-1