Icom 271 - loose piece

Discussion in 'General Technical Questions and Answers' started by CT1BRM, Jan 11, 2020.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: Left-3
ad: L-MFJ
ad: MessiPaoloni-1
ad: Left-2
  1. CT1BRM

    CT1BRM Ham Member QRZ Page

    Hi,

    I bought an Icom 271, in the shipping there must have been an impact and a piece jumped, it was inside the radio. I don't know where your place is, can anyone help please? I attach a photo.

    73' CT1BRM
    JM Nunes
     

    Attached Files:

  2. AA7QQ

    AA7QQ Ham Member QRZ Page

    If it's transparent, I do not remember one in mine. It may have gotten in the hatch.

    Ed
     
  3. KG4RZU

    KG4RZU Ham Member QRZ Page

    I second Ed's answer. I pulled covers off of mine just out of curiosity and could not find anything resembling what is pictured. Plenty of vent slots on top and bottom- it could have dropped in off of something else from previous owner. If you are new to the 271, be sure to keep a good memory battery on the RAM board.
     
    AA7QQ likes this.
  4. CT1BRM

    CT1BRM Ham Member QRZ Page

    Hi, KG4ZU - Raymond

    Thanks about the information, I agree, it could have dropped in.
    Yes, it's the first time that I have a Icom 271, why it's important to keep a good memory battery on the RAM board? For not lose the memories or there are another problem. I have seen the battery solered in a board, it's not easy to remove.

    73' CT1BRM
    JM
     
  5. CT1BRM

    CT1BRM Ham Member QRZ Page

    Hi, KG4ZU - Raymond

    Another question and information, I have the IC-1271E and I'm looking for the IC-471, but my question it's about the power on. When I power on the equipment the display have a delay to show the frequency, is the smae in the two equipments. Is normal these situation?

    73' CT1BRM
    JM
     

Share This Page

ad: QSKLLC-1