IC-7600 and WIN10 USB driver problem

Discussion in 'Computers, Hardware, and Operating Systems' started by SQ5EBM, May 30, 2018.

ad: L-HROutlet
ad: l-rl
ad: MessiPaoloni-1
ad: l-assoc
ad: L-MFJ
ad: Left-3
ad: Subscribe
ad: Left-2
  1. SQ5EBM

    SQ5EBM Ham Member QRZ Page

    I am an IC7600 owner. SInce few last days, last WIN10 update my TRX is not cooperating properly with WIN10. CAT is working and i can see it in my Device Manager as a com port but no signs the other com port - for sound card (icom). I can see my icom as usb speakers and mik in Windows but it does not cooperate with digi modes software. There used to be 2 com ports when 7600 was connected. Now only 1 is there.

    I did download new Silicon Labs drivers but it did not help.

    Could You help me in solving that problem? For now i am cut off from all digital modes and Winlink connection that we use in our SP EMCOMM.

    The only solution seems to be to delete Win10 and go back to Win7 but to do so i need some free time.

    With kind regards
    Maciej "Miles" Muszalski
    SQ5EBM/SN5V
     
    Last edited: May 30, 2018
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    Try this.

    With the April update, many folks have needed to go into Settings/Privacy/Microphone and make sure "Allow Apps to access your microphone". This should fix the sound card problem. You might, at the same time, turn OFF those devices that this activates (immediately below the mic switch) that you don't want on. I know - stupid to call it "microphone", but it does allow the speaker/microphone to work again. Quite possible this will allow using the RigBlaster control as well.

    Good Luck
     
  3. SQ5EBM

    SQ5EBM Ham Member QRZ Page

    Don, You are my hero! :) Maaaan... if you were down here i would buy you a big bottle of vodka.
    Thank You so very much! It worked. I feel like hugging You :)
     
    WF7A and KA9JLM like this.

Share This Page