ad: TiltPlate-1

HRD Commercial Version - COM Port Hangs on Closing

Discussion in 'Amateur Radio Software' started by KC1UA, Nov 12, 2017 at 3:10 PM.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: K3QNTad-1
ad: L-rfparts
  1. KC1UA

    KC1UA XML Subscriber QRZ Page

    Hello,

    I'm testing the commercial version of Ham Radio Deluxe. I'm using it with a Yaesu FT-450D via a USB to serial bridge (COM5 on my setup). It performs fine until I attempt to close HRD Rig Control. When it gets to closing the COM Port it hangs, with a small pop up indicating "Closing... (Not Responding) with the blue progress bar stalled. This results in me having to force the program closed. If I try to re-run the program it tells me that the COM Port is in use, obviously because it never was released due to the abnormal termination of the software.

    I've searched the interwebs and come up empty. My registration at HRD's forums is pending so can't ask there yet. I'm stumped. I'm also happy I'm on the 30 day trial as no solution for this would be a deal-killer.

    My #1 suspicion would be the USB to serial bridge but aside from this issue it seems to work flawlessly.

    Any thoughts would be appreciated, with thanks in advance.

    73.
     
  2. W8MRL

    W8MRL Premium Subscriber QRZ Page

    This has so many variables in it, your operating system, installed programs, various drivers etc. You'll really need to work with their support team and let them remote in. This is definitely on the PC side of things.
    I've run HRD for 5 years and you'll love it when you get by this issue.
     
  3. KC1UA

    KC1UA XML Subscriber QRZ Page

    Agreed, the variables are off the charts! I have used the same FT-450D and the same USB to Serial Bridge using SDR-Console software and controlling the 450 as the external receiver. OmniRig has to run beneath SDR Console to make the connection work, and never a hiccup with that. That said though I know this setup is far more sophisticated in control of the 450.

    There's a lot to HRD as you well know but thus far this really is my only deterrent thus far. I have a LOT to learn but the basics are working out very nicely. I'll continue to experiment and do more research and will call on their tech support only as a last resort. I believe I can't test on another PC while in trial mode as the temporary license issued is associated with my callsign.

    Thanks for the response.
     
  4. KC1UA

    KC1UA XML Subscriber QRZ Page

    I think I may be able to answer to my own dilemma...

    Don't use the aforementioned ATEN USB to Serial Bridge! I happened to stumble upon an old Keyspan USB to serial connector I forgot I had. I've always had good luck with Keyspan devices and this one didn't let me down either. I did reduce the baud rate on the 450D to its default of 4800 also. HRD Rig Control then shut down for me as I'd expect it to.

    I had also tried to reduce the baud rate while using the ATEN. The result? 3 consecutive BSOD's after a few minutes of running HRD. That device will be reassigned to the junk box. It's unfortunate that today's PC's by and large don't continue to provide at least one true serial port as a standard, but it seems for the most part that such devices are things of the past.

    I was fortunate to find the Keyspan, so I'd say (hope) that this "issue", apparently having nothing to do with HRD at all, is resolved.

    73,
    Scott
     
  5. W4NNF

    W4NNF XML Subscriber QRZ Page

    I think you've solved your problem. One thing I've found is that the Keyspan is the only serial-USB converter that works consistently.
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    I think it is a combination of both HRD and the adapter driver.

    The port is not being released properly. That can put your radio into unexpected transmit. :eek:

    Great that you have a work around.

    Have Fun.
     

Share This Page