HELP! Windows 10 SCU-17 Driver (Virtual Com Port Driver)

Discussion in 'Computers, Hardware, and Operating Systems' started by AA5TN, Nov 19, 2017.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: Left-3
ad: Subscribe
ad: L-MFJ
ad: MessiPaoloni-1
  1. M7POE

    M7POE Ham Member QRZ Page

    I have a windows 10 laptop. I have tried everything I know to install SCU-17 USB Driver(Virtual Com Port Driver). for my Yeasu FT450D
    the driver will not install properly and in propertys on the driver

    This device cannot start. (Code 10)

    The specified request is not a valid operation for the target device.

    is the message I get ? it originally in stalled on one laptop and worked for a short will but now does not? Tried on another laptop and will not install properly on that one either. Tried un install & reinstalling many times but no luck.
     
  2. W9GB

    W9GB Ham Member QRZ Page

    First, you will need to remove “the artifact mess” created by these failed VCP installs.
    USE Device Manager with Option to SHOW Hidden Device Drivers.
    Do NOT have anything attached to your Laptop, when installing these VCP drivers.
    ==
    Note: Do not connect the USB cable and Yaesu SCU-17 to your personal computer until AFTER the VCP (Virtual COM Port) driver installation is completed, because an incorrect driver (MS Win) may be installed.
    http://radioaficion.com/cms/scu-17-usb-interface-unit/

    Yaesu SCU-17 Manual
    http://www.yaesu.com/jp/manuals/ol/scu-17_om_eng_jpn_eak21x700.pdf

    QRZ Tech Forum Discussion (2014), What’s inside the Yaesu SCU-17
    http://forums.qrz.com/index.php?thr...-scu-17-usb-soundcard-transceiver-ifc.425728/

    Silicon Labs CP-2105 Discussion
    https://groups.io/g/nbems/topic/25360895

    CP210x USB to UART Bridge VCP Drivers
    https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
     
    Last edited: Sep 13, 2019
  3. M7POE

    M7POE Ham Member QRZ Page

    Have un installed the driver and tried again to no good ? when installing it looks like is installing file which lasts less than a second to install . Says it
    plug the cable nothing apperses in the Device manager even if you click to show hidden . You have to click hidden & then add a legucy device and sellect the Siliconlabs Driver then it appears in the device manager with a yellow triangle. the divice driver still has this message

    This device cannot start. (Code 10)

    The specified request is not a valid operation for the target device.

    Uninstall it all as suggested and reinstall with nothing pluged in as suggested still does not install tried every possible combination of things even older drivers for the SCU-17 Still no luck. Even wiped the laptop and reinstaled windows 10 a few times just incase it was windows 10 corupt.
     

Share This Page

ad: KF7PMW-1