Help - Tytera MD-390 USB driver

Discussion in 'Echolink/IRLP Tech Board' started by KI4FVO, Jun 21, 2016.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Subscribe
ad: L-MFJ
ad: Left-2
ad: Left-3
  1. DJ7WL

    DJ7WL Ham Member QRZ Page

    Have also Driver Problems. Have just received my TYT MD 390 GPS. Connectet it to my WIN 7 64bit pc via the programmer cable. Ok, shows me "Digital Radio in USB Mode Driver searching" ok fine little later i see the message "STM Device in DFU Mode succesfull installed". Now i installed the CPS Software ver. 1.36 Try to connect my Radio to read and write codeplugs. But no connection is present and i dont see the Basic datas present in the CPS. Need help to overcome this Problem. VY 73 Joachim DJ7WL near Hamburg/Germany
     
  2. LB5HG

    LB5HG Ham Member QRZ Page

    Hi Joachim, I'm experiencing the exact same problem that you describe with my new 390-GPS. Where you able to find a solution?

    73 de LB5HG, Thomas
     
  3. N2ITR

    N2ITR Ham Member QRZ Page

    Hi Guys. Manny here (N2ITR). I just finished interfacing my MD-390 to Windows 7. I can "talk" to it and read from it. I was initially successful with programming an analog channel just to verify data transfer. It works.

    Here are some of the issues I ran into:
    1) The supplied CPS (computer programming software) reported the radio as the "wrong model" when I initially tried to write to it or read in from it. Solution: Find an updated software higher than rev 1.30. I am now using v 1.36. It works perfectly.

    2) I also initially had USB problems. I discovered the following:
    a) The cable supplied with the radio is NOT a USB to serial cable. It is a straight-through cable. The USB interface is INSIDE the radio. It requires a separate driver that no version of Windows (I'll call it the Windows Driver Cloud) supplies. The fix is, included with the v 1.36 CPS is the USB driver(s) that addresses this. To install it, do the following:
    i) Power up PC; allow Windows to finish booting.
    ii) Right-click on "My Computer" or "My PC" (the upper-left icon on the desktop). Alternately, open Control Panel and locate Device Manager icon; click on it.
    iii) Attach USB cable to radio and power the radio on.
    iv) Connect USB cable to any USB port (hopefully on the front or side of your computer; laptop or desktop).
    v) The Devices list in Manager should update with your device with a yellow marker (flag-like highlite). It should first appear under "Other Devices."
    vi) Right-click on device and select "Update Driver." DO NOT ALLOW IT TO SEARCH THE WINDOWS DRIVER DATABASE - IT WON'T FIND IT THERE.
    vii) Locate the folder where you installed your CPS and there should be a USB sub-folder there. Point to it and click "OK."
    The installer should find the appropriate driver under that folder tree and install it. Your device will now appear under the USB Hub listings in Device Manager. You should be able to click on it and verify the status of the driver. It should say that it is working properly.

    You should now be able to talk to your radio using the v 1.36 CPS. I suggest you first read the radio in so that the radio data can be received. The very NEXT thing you should do is program your ID code into the general data page and give the radio a name (preferably, your callsign).

    You should now be on your way to digital radio communications.

    Best 73.
    Manny Fernandez, N2ITR
     
  4. W4END

    W4END Ham Member QRZ Page

    Thanks Manny for the direction. When my computer (Win10) says I already have the most current update ... then what? I have tried to delete/uninstall the prolific USB driver that shows up when I plug in the TYT cable and somehow Win10 reinstalls it. Looking for directions on how to force my computer to only use the USB drivers that you suggested.

    Here is what I have done - I went to this website and downloaded the CPS file and USB drivers: http://www.va3xpr.net/programming-software-firmware/ I can get the CPS program to work just fine until I try to read/write to my MD-390 GPS. I get the standard error saying to please check my USB is connected or otherwise in use...paraphrase. Yes, moving the cable around to different ports the device manager changes showing which port it's connected too. Very frustrating this prolific issue has become.

    Again, thanks for any help
    73
    Paul
     
  5. TA3AJR

    TA3AJR Ham Member QRZ Page

    Hello, I can't install the uv390 md driver. I tried it in windows 7, windows 10. please help me. I cannot enter frequency. 73
     

Share This Page