Help Needed (settings) - FT-857D, SignaLInk and WSJT-X

Discussion in 'Working Different Modes' started by N1TYH, Jan 29, 2015.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: HRDLLC-2
ad: abrind-2
ad: L-Geochron
ad: Left-2
ad: MessiPaoloni-1
ad: Left-3
  1. N1TYH

    N1TYH Premium Subscriber QRZ Page

    Is anyone successfully running WSJT-X Version 1.4rc1 (JT65 digital) on the FT-857D using a SignalLink USB and a Mac running Yosemite? If so, I would greatly appreciate help (understanding your Sound Card settings, FT-857 settings, etc.). [FONT=Helvetica, Arial, lucida grande, tahoma, verdana, arial, sans-serif]It seems as though I can receive just fine. However, I'm having difficulties transmitting (the SignaLink PTT light turns on and the radio goes into transmit mode, but then both drop out immediately while WSJT-X shows it's still transmitting). I did find a tip online that the radio should be at RF Power at 100, and output controlled by the Signaling's Tx knob. I'm not sure if I have the sound cards setup correctly in Yosemite's preferences (I have system sounds going to headset, USB Codex output set at about 75%).

    I made my first 4 RTTY contacts this past weekend in the BARTG sprint (using cocoaModem). So, I believe the SignaLink is working fine. However,
    [/FONT]I readily admit that I'm new to digital HF and also a new OS X user (having converted from Windows only 4 months ago). So, these may be rookie questions on both fronts.[FONT=Helvetica, Arial, lucida grande, tahoma, verdana, arial, sans-serif]

    Thanks again for any help or tips.

    73,
    Steve (N1TYH)
    [/FONT]
     
  2. KQ0J

    KQ0J XML Subscriber QRZ Page

    I have an FT897 not 857 but if I do not have the sound levels in the USB Codec for the signalink I have xmit problems or no xmit. Make sure the USB Codec driver in the PC is set at 100%. Yes you can have radio output set at 100W / % and then vary the xmit power by the TX knob on the signalink.
     
  3. KK4PP

    KK4PP Ham Member QRZ Page

    I'm running the Windows version of WSJT-X on my MacBook Air using Crossover. Initially, I had some trouble with the Signalink dropping out of transmit. A couple pointers...


    The audio volume on your Mac has to be turned up all the way. If it's at less than 100%, the transmit will drop out every time.


    If you are using a USB hub, definitely get rid of it and plug the Signalink directly into the Mac for testing purposes.


    My Signalink drops out at times when I use the USB port on the right side of my Macbook Air. I have never had any problems with the port using any other device. I switched to the left side port near the Magsafe charging connector, and all my problems seem to be solved. I would try switching ports, and then try switching cables. If you read the troubleshooting page from Tigertronics, the first thing they say to try is switching ports and then switch cables.


    The problem you are having will not be affected by adjusting the Tx, Rx & Dly knobs on the Signalink. Don't bother fiddling with them to see if it helps.


    If you hold down option and click the speaker icon on the top right of your desktop, it gives you a quick option to change your input & output sources. It's a faster way to check your settings than opening System Preferences. If you do change settings, make sure any programs listening to or generating audio are turned off. OS X doesn't consistently change audio sources/outputs while there is any audio present. (Turn the Signalink on & check your sources BEFORE starting the WSJT-X software.)


    Hope one of these little tidbits of info helps...
     
  4. KE5MC

    KE5MC Premium Subscriber QRZ Page

    Steve,

    Check your setting in WSJT-X that you are not using CAT commands to key the radio as the SignaLink is doing it too. I have seen similar issues when setting up or making changes in my shack. Results at the radio are unpredictable when PTT comes in on two different paths.

    What got my attention was you made 4 RTTY contact which means you are using a different program with the same hardware path and connection. Good chance the RTTY program is setup for PTT=None or VOX.
     
  5. N1TYH

    N1TYH Premium Subscriber QRZ Page

    Thanks to everyone for the suggestions. I've been fighting this off and on for a few days now. It works, then it doesn't (very frustrating). I uninstalled WSJT-X, removed the directories and started from scratch. I won't say that did it, because I still had issues when I first launched the program.

    Here's what's working now on my Mac Mini (running Yosemite) and my FT-857D.
    a) Set sounds to Max.
    b) On the Mac, made sure I selected "headphones" (not USB Codex) before exiting. I read online that you shouldn't keep the USB Codex under output highlighted blue when exiting System Sound.
    c) I do have an external USB port (powered), but I wasn't using that. I use the USB ports on the back of the Mac Mini. I did have to move to a new USB port. Everything else wouldn't work until I did that. Hopefully that does the trick.
    d) Also, based on the suggestion above, I make sure the Signaling USB is turned on before launching WSJT-X.
    e) I also use "tick.usno.navy.mil" for the clock setting (versus using the Apple selection from the pulldown).
    f) I do not have my FT-857D attached to the computer via CAT. I have an FC-30 auto tuner that takes that port. I found an DIY connector that I can make online and use the microphone port for CAT. The connector allows you to have the microphone and CAT cable plugged in at the same time.

    Thanks again to all. My fingers are crossed that this does the trick. Hope I see your calls on JT65.
    73,
    Steve (N1TYH)
     
  6. KQ0J

    KQ0J XML Subscriber QRZ Page

    You also may want to try the Yaesu Ft-857 forum on Yahoo if you have not already..

    Good luck hope to work you.
     
  7. N1TYH

    N1TYH Premium Subscriber QRZ Page

    Thanks to everyone for the advice. I will check the FT-857 forum on Yahoo. I don't think the issues that I have are with the radio, and I doubt it's the SignaLink because both work great with Cocoamodem in RTTY mode. It's something with WSJT-X sending a sound. I've switched to every single USB drive. Works for a while, then doesn't anymore. I found a quirky thing where I have to play several seconds of a song through iTunes and my speakers. Then the SignaLink USB seems to work. Very odd. I'll get it working eventually. Next steps are to try a new USB cable, and then to see how it everything performs on an older MacBook. Maybe some of the issue are with OS X and Yosemite interacting with WSJT-X (again because Cocoamodem seems to work well).
     
  8. KF6BL

    KF6BL Ham Member QRZ Page

    I might be in left field here, but...

    I don't think that WSJT is sending any sounds. I do believe it is sending digital data to the sound card which in turns creates audio tones for transmission. So lets look at it from that standpoint. I know that I first had similar issues with my Win7 machine. I am still having some minor issues after running RMSExpress and WINTOR that my WSJT does not decode properly.

    To make sure all is working correctly I have to ensure that my choice of CODEC is what has been loaded by Win7. I do not know MACs but I am sure it is basically the same; drivers get loaded to the USB port in use. If I switch USB ports from the Singalink, WSJT will not work, so I have to maintain use on the frist port it was installed on. Might be a Win7 quirk, but none the less it is what it is.

    I would look at what ports are being used (in windows it is under computer management, not sure about the MAC). I would then clear all the ports and then connect the Signalink and let the MAC configure that port for its use. Then point the WSJT to only that port/CODEC. Hopefully that will clear the problem.

    About my WINMOR/JT65 issue I am still working on that. It does work but I have to do a little playing around. As if the software RMSExpress or WSJT is not releasing the port after it closes.

    Sorry if I repeated anything that was mentioned above. Good luck.
     
  9. K5UNX

    K5UNX XML Subscriber QRZ Page

    So I had the same issue. I finally found a setting that would give me reliable JT65 with WSJT-X. I am running it on a Win 7 laptop though but that may not make any difference.

    Just to make sure we're talking the same thing . . . I have the data connection from the radio to the SignaLink. USB cable from SignaLink to computer. CAT cable from FT-857D to the computer. Here is a screen shot of my WSJT-X config.

    wsjt-config.JPG

    I wanted to use CAT to allow me to change the radio freq using WSJT-X. So I enabled CAT. I originally had PTT set to CAT as well but I as having the issue you describe. The radio and SignaLink would appear to be transmitting but nothing was . . . I then did a lot of reading through the support materials on the SignaLink web site and found that the SL also sends a PTT to the radio. The support materials on the SL website indicated somewhere to try VOX . . . So I set VOX as the PTT method in WSJT-X and tried that. Ever since, I have not had the problem repeat. My theory is the SL and WSJT-X were sending PTT to the radio. I think there was a race condition and if a certain one got there first, the problem was would happen, and if the other one got there first, it wouldn't. Regardless, I no longer have the issue and have 100% reliable JT-65 using WSJT-X.
     
  10. N1TYH

    N1TYH Premium Subscriber QRZ Page

    KF6BL and K5UNX,

    Thanks for the tips. I've tried various solutions. Still the same issues (transmits fine first time, then cuts out each subsequent time). I've listened to WSJT-X output over the speakers (selected speakers versus USB Audio Codec) and all sounds fine. I believe there's something going on between my Mac and SignaLink. Exactly what, I do not know. It's frustrating because Cocoamodem works perfectly (for RTTY). I use Cocoamodem without CAT as well. If it didn't work with Cocoamodem, I'd suspect the SignaLink. However, that works perfectly fine.

    I also have the USB cable from the SignaLink USB to the computer. I'm using the FC-30 Auto Tuner, with WSJT-X. Therefore, I can't use CAT at the moment, because the CAT/Tuner port is taken by the tuber. I'll remove that and hook up my old MFJ manual tuner. I'll connect the CAT cable and see if that resolves the issue. I doubt it. I spoke with John (WSJT-X programmer) and he said the program should work fine with a radio connected.

    On the FT-857D side, I have the radio in Digi mode, menu 038 set to User-U <for USB>, and menu 039 digital shift set to 1100. I've tried menu 039 <digital shift> at zero, 1500, and a few others. Doesn't make a difference.

    I'll try an old Mac notebook (running Lion) and see if that works. If so, then something is messed up with Yosemite or my Mac Mini. Wasted too much time trying to resolve this. Maybe someday Cocoamodem with come out with a JT65 module.
     
Thread Status:
Not open for further replies.

Share This Page