HELP - Can't Get Tytera MD380 DMR Radio USB Driver To Work On Windows 10

Discussion in 'Echolink/IRLP Tech Board' started by KB0OXD, Jan 20, 2016.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-2
ad: MessiPaoloni-1
ad: HRDLLC-2
ad: Left-3
ad: L-Geochron
ad: abrind-2
  1. KB0OXD

    KB0OXD Ham Member QRZ Page

    Just got my Tytera MD380 BUT I'm having problems with programming it.


    Simply put, I plug the programming cable from the radio to a USB port. Windows acknowledges this connection with it's usual beeping sound but then NOTHING HAPPENS

    What doesn't help matters any is there is NO self-extracting executuable to manually install the driver NOR does Windows even bother searching for it (And ADD/REMOVE HARDWARE within control panel is o help either (I know having just tried it))

    As it is now, I CANNOT EVEN BEGIN to do anything but charge the radio (Probably needs that anyway) as I can't even complete the process of entering THE MOST BASIC INFORMATION about the radio (Like the serial number - WHERE IS THAT ??), MUCH LESS do anything else with it

    I really need HHHHHEEEELLLLLPPPPP !!!!

    Cheers & 73 :)
  2. M0OAB

    M0OAB Premium Subscriber QRZ Page

    The serial number should already be stored in the radio, you just need to input your call sign and the ID# number you got given when you registered for the dmr network.
    sometimes these program cables fail to register as a com port but instead just a usb connection but it does still transfer your code plug to your radio, only slower.

  3. KB0OXD

    KB0OXD Ham Member QRZ Page

    Well I can try plugging the cable DIRECTLY into the USB port rather than thru a hub controller & see if that works but if that don't work, then SOMETHING has GOTTA be defective.....

    Cheers & 73 :)
  4. KC9YTJ

    KC9YTJ XML Subscriber QRZ Page

    If you plug the cable into the USB port but not the radio, does the computer beep? If it does, you have the wrong cable. The TYT cable is a "dumb" cable with no FTDI chip (it's built into the MD380). There was a warning somewhere some months back about trying to use a Baofeng-style FTDI cable with the Tytera; it doesn't work, and may damage the radio.

    Otherwise I'd recommend (as you have noted) plugging into a USB port on the computer. External hubs can sometimes throw a monkey wrench into things.

    Good luck!
  5. KB0OXD

    KB0OXD Ham Member QRZ Page

    It doesn't beep.

    As for the cable I'm using, I'm using the TYT cable that came with the radio (No foreign or homebrew jobs)

    As for programming the radio, I've managed to program repeaters but NO talkgroups as of yet. Also, the display DOES NOT shift to the input when the PTT is pressed (Perhaps that's because the transmissions aren't being directed at any talkgroup in particular since the local system IS NOT a closed one like a lot of DMR systems are ALTHOUGH only a couple of repeaters are tied to the MARC system itself while the rest are local/regional)

    The system I'm looking at is based on the listings @ (Mostly under the DENVER & BOULDER areas since that's where I live :) )

    Cheers & 73 :)

    Pat, KB0OXD
  6. N3XEY

    N3XEY Ham Member QRZ Page

    Iam having same problem,only on windows 7.0
    What gives any expert out there from N3xey
    Any help would be great!
  7. KB0OXD

    KB0OXD Ham Member QRZ Page

    The solution I got (With help from Jeff, K0JSC) was that you have to do this.....

    * Download the codeplug from YOUR LOCAL DMR GROUP WEBSITE (This is VITAL as this contains all the info. you need to access the system)

    * Using the MD380 software, open the RDT file & write it AS IS to the radio (Don't forget to add YOUR USER ID that you obtained from THIS WEBPAGE)

    * Now have the software READ the same data FROM THE RADIO (This provides the software with the Unique Device ID)

    * Next compare what's on the radio with what you see in the software (If what you see in the radio display matches what you see in the software, then everything else should be okay

    * SAVE THE RDT FILE TO YOUR COMPUTER (And to cloud space you have too for backup purposes) !!!

    IF THE CODEPLUG IS WRITTEN CORRECTLY, all repeaters (Including your favorite analog hangouts) should be accessible (Barring things that plague analog communications such as NOT ENOUGH ANTENNA, which is currently my problem. No amount of codeplug tweaking can make up for that (Gotta get me a mag mountie from da candy store ASAP if I'm to really enjoy working DMR from home :D )

    Hope this helps :)

    Cheers & 73 :)
  8. KA1RTW

    KA1RTW Ham Member QRZ Page

    Just bought a TYT MD-380 and windows 7 won't recognize the device. It see's it as a problematic USB device and will not allow it to engage. I can open the software program, however nothing I type (such as the serial number of the radio; or my DMR number) will go into the program. Tried updating the driver. Windows says the correct driver is already installed, so it just won't allow me to use it. HELP! M. Grace/KA1RTW
  9. KA1RTW

    KA1RTW Ham Member QRZ Page

    Oh yes, forgot to add. I am using the TYT cable that came with the radio.
    M. Grace/KA1RTW
  10. KD4MOJ

    KD4MOJ XML Subscriber QRZ Page

    Install the 1.30 software and your troubles will go away. The software contains the "driver".


Share This Page