Hair tearing! fldigi and OSX (High Sierra) with FT911A

Discussion in 'OS: Mac OS' started by G4JJP, Dec 9, 2019.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: OK1UUad-1
ad: Left-2
ad: Subscribe
ad: Left-3
ad: FBNews-1
  1. G4JJP

    G4JJP Ham Member QRZ Page

    I'm really tearing my hair out here! Trying to get my Yaesu FT-911A to talk to fldigi on my macbook pro. Anyone else found a way to do this? I'd really appreciate some help.
     
  2. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Should be the same as for any other Icom/Kenwood/Yaesu rig with a built-in USB port.

    ***Make sure your rig is disconnected from the computer (no USB connection AT ALL to the rig)***

    Install the latest SILabs driver from https://www.silabs.com/documents/public/software/Mac_OSX_VCP_Driver.zip

    Reboot

    Go to your Security Pane of the System Preferences and allow the extension to run.

    Only now connect your rig to the computer.

    Download and install Fldigi. Start it and go through the setup. Leave RigControl untouched for now. Save CONFIG, go to Fldigi File Menu and select "Folders, Fldigi config. Now close Fldigi (leave the Finder window open!)

    Download the XML definition file for the 991 from https://sourceforge.net/projects/fldigi/files/xmls/yaesu/FT-991.xml/download

    Copy the downloaded XML file from your Downloads folder to the rigs folder in the Fldigi config finder window.

    Startup Fldigi. Go to Config, and select Rig Control. Chose RigCat and select "Use RigCAT". Next to Rig description file, click the open button and choose the XML file you just copied over. Under device, look for a serial device that is labeled SLAB_USBtoUART: it may have a number after it, or there may be more than one. Select it, make sure you baud rate matches that of your rig (double and triple check), click "Initialize" and you should be connected. If so, hit "Save", then "Close", then "Save CONFIG" in the Config menu.

    I may have mislabeled a field or two above as I'm typing this from memory while on my dinner break, but you should be able to figure it out.
     
  3. G4JJP

    G4JJP Ham Member QRZ Page

    Thanks. That's brilliant. I've found where the issue is. You say: "Under device, look for a serial device that is labeled SLAB_USBtoUART" Despite having installed the driver, it doesn't show. So there's the issue. Now need to sort it!

    Again, thanks.
    G4JJP
     
  4. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page


    The either the driver was not installed correctly (make sure that the rig is NOT connected to the computer when doing the installation -- not merely powered down, but completely disconnected at the physical level), or you have not allowed the extension to load in the Security preferences.
     
  5. G4JJP

    G4JJP Ham Member QRZ Page

    Thanks. Reinstalled successfully, and it shows in Rig Control. Selected OK, and Init holds the tickbox. Rig Control now working, but still nothing in the waterfall. I keep thinking I'm so nearly there!! Thanks for your help.
     
    K3DCW likes this.
  6. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    The audio should be selected to be USB Audio CODEC. You may have to go to the Security preferences and allow Fldigi to have access to your "microphone" (the USB Audio CODEC) in order for anything to show up.
     

Share This Page