ad: wmr-1

HA-10 Warrior Panel Meter

Discussion in '"Boat Anchor" & Classic Equipment' started by N2TC, May 11, 2021.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: L-Geochron
ad: abrind-2
ad: HRDLLC-2
ad: MessiPaoloni-1
ad: Left-2
ad: Left-3
  1. N2TC

    N2TC Ham Member QRZ Page

    Hi all:

    Been restoring an HA-10 and just got my new swinging choke from Hammond installed. Popped in a pair of 3B28's and fired it up. Hit the power switch: 811A filaments light up along with the pilot light. No smoke. Swallowed hard and hit the HV switch. Red pilot came on and again no smoke, snap-crackle-pop or small explosions. Yay!

    However, the panel meter reads nothing in either HV or plate current setting. No HV or bad meter/circuit? Well, my VTVM shows not only HV but pretty close to the CORRECT HV. Cool. Shut things down and waited for that ancient but indestructable oil-filled filter cap to discharge. Checked HV meter circuit resitances and, other than the three 4.7 ohm paralleled. resistors reading a tad high (2.4 vs expected 1.56), all hot, straight and normal. Good continuity to and through meter switch. Was able to get the meter to deflect to full scale using the lowest resitance setiing of my VOM, so meter not completely dead -- but could it not still be defective? The fact that it doesn't read correct plate resting current either (without cutoff bias - barely moves off of zero) suggests to me that the meter is defective as the PA current and HV metering circuits have only the meter itself in common.

    I would appreciate someone weighing in on my thinking thusfar. Any logical mistakes? Have I forgotten anything? Also, if the conclusion is to replace the meter, how likely is it that I will even find one?

    Thanks for any help.

    Tim
    N2TC
     
  2. W1UO

    W1UO Ham Member QRZ Page

    Did you check the meter switch grounds (#5, 9, 10)?

    upload_2021-5-11_14-57-3.png
     
  3. N2TC

    N2TC Ham Member QRZ Page

    Yep. All good. Wish it was that easy!
     
  4. N2TC

    N2TC Ham Member QRZ Page

    And it gets a little more weird. Checked the internal meter resistance and it is 61 ohms vs. a 50 ohm spec so that would seem to NOT be the issue. Running out of things to check; Meter bypass cap maybe (was not in circuit for meter resistance check)?
     
  5. W5RKL

    W5RKL Ham Member QRZ Page

    You can easily check the meter with a 6V lantern battery and a series voltage drop resistor calculated using Ohms Law

    R - E / I

    6 / 0.001 = 6000 ohms

    The meter is 1ma FS. With a 6V lantern battery, a series resistor of 6K, the meter should rise to FS. Since normal resistor
    values don't include 6K but rather 6.2K, the meter will rise up but stop just shy of FS. This indicates the meter is working
    properly.

    73
    Mike W5RKL
     
    N2EY likes this.
  6. N2TC

    N2TC Ham Member QRZ Page

    Thanks. WIll try that. If meter is good (that would be helpful), not sure what else is going on.
     
  7. N2EY

    N2EY XML Subscriber QRZ Page

    Or use a 1.5 volt battery and a 1500 ohm resistor.

    Make sure the meter movement is isolated from the rest of the circuit.

    73 de Jim. N2EY
     
  8. W7JMP

    W7JMP Ham Member QRZ Page

    One other possibility to check is for oxidation in the meter switch.

    I recently put a Heathkit Warrior into service and not all the meter functions were working. It turned out to be oxidized contacts in the meter function selector switch. Some de-Oxit and careful rubbing with a pencil eraser cleaned it right and my HA-10 is in regular use now.
     
    N2EY likes this.
  9. N2TC

    N2TC Ham Member QRZ Page

    Meter passes the FS test with flying colors so it isn't that. Going to check the voltage across the HV metering resistors next.
     
  10. N2EY

    N2EY XML Subscriber QRZ Page

    Better yet, check their resistances with the amplifier completely de-energized.

    Also note this: If the bias jumper isn't in place, the tubes will be biased to cutoff and there won't be any plate current.

    And - because the HA-10 was a kit - don't assume it was assembled correctly in the first place.

    73 de Jim, N2EY
     
    W9GB likes this.

Share This Page

ad: Radclub22-1