ad: Radclub22-1

FT1DR Internal Charger

Discussion in 'General Technical Questions and Answers' started by NU1A, Aug 11, 2016.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: abrind-2
ad: Left-2
ad: L-Geochron
ad: Left-3
  1. NU1A

    NU1A Ham Member QRZ Page

    I have a silver Yaesu FT1DR handheld radio that will not charge the battery fully. I have been using the rapid charger to charge the battery, but once I decided to try using the internal charger. After several hours of charging time, I turned on the radio to find that the battery had a charge of 7.2 volts, while it should have read about 8 volts.

    After powering down the unit, I plugged in the radio again, but the display read: "NO BATTERY."

    I decided to watch the charging process of a depleted battery closely. After about 30 minutes of charge (2 bars on the charge progress) , the screen stopped displaying "CHARGING" and shut off.

    My black FT1DR can charge the battery fully to 8 volts. Does anyone know what could be causing my silver radio to shut down after 30 minutes of charging?
     
  2. AE7RZ

    AE7RZ Ham Member QRZ Page

    Have you tried swapping the two batteries? Maybe the one in the silver radio is bad.
     
  3. NU1A

    NU1A Ham Member QRZ Page

    Yes, I have tried to charge 3 different batteries, but with the same result.
     

Share This Page