FT-991A and WSJT-X Problem

Discussion in 'General Technical Questions and Answers' started by W9BRI, Aug 14, 2017.

Tags:
ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: L-MFJ
ad: Subscribe
ad: Left-2
  1. KW4EK

    KW4EK Ham Member QRZ Page

    A
    At least with past versions of FlDigi you had to run with Vox enabled and dataport set to the Vox input when using the SCU-17 interface, which is the interface that Yaesu has built into their radios with USB Ports. You need Vox mode because FlDigi does not (at least in the past when I last tried) support CAT control on one Com (serial) port and PTT on another Com port, it wants to do both on the same serial port but enabling such on the CAT port tends to enable the microphone input and not the data audio port. In the interests of full disclosure I run an FT-950 with the SCU-17 (the SCU-17 having the same chipset built into their USB radios), so the implementation should be very similar for us both.

    On those who get transmit on their radios but no power output, you will have a problem somewhere with your audio settings. It may be that the wrong audio output device has been selected or that the audio level has been set way too low in either the windows audio mixer (for the FT-991 soundcard interface) or, in the case of WSJT-X the left-hand power slider bar may be set too low and need adjustment upwards. It may also be that your radio is not configured to look at the digital audio port and is expecting audio from your microphone (you can test this by speaking into the mic to see if you get transmit output) or that the digital data audio input volume level is set too low in the radio menus (I know my FT-950 allows menu adjustment of input and output audio levels on the data port, so the 991 may also).

    Also, be aware that if you are running a rig control application, such as HRD, then that application will own the CAT serial port and all CAT control must be through the rig control application and not direct to the serial CAT port by the digital modes software. If your digital mode software does not know how to communicate with your rig control application directly then you may need to resort to Vox mode to enable transmit or you may need to close your rig control software so that it can surrender the CAT serial port to the digital modes application. The reason this is so is because serial ports, even virtual USB ones, are exclusively owned by the first application to claim them and may only be accessed by one application at a time (i.e. exclusive ownership by the application on a first come first serve basis).

    These are a few of the possibilities to check out and will hopefully get you up and running. I always tell people that the greatest challenge in working digital modes is not the mastering of the mode or software but figuring out the optimal and correct setup for your HF rig the very first time as each is a bit different and there are several different solutions on the market which do similar things but which are also setup somewhat differently. But the biggest challenge is getting your computer, the digital modes interface (which is embedded with your radio), and the radio all talking to one another properly and the more things there are to make work in the chain the more opportunities there are for something to be setup wrong or suboptimally.

    Just do not give up as you will get there!
     
  2. WA6PHR

    WA6PHR XML Subscriber QRZ Page

    I use the following Menu settings on my FT-991 with WSJT-X latest version:
    029 38400 bps
    031 38400 bps
    033 Disable
    059 Direct Freq
    062 Others
    064 1500 Hz
    065 1500 Hz
    066 Off
    068 Off
    072 USB
    All other menu settings Default.

    WSJT-X
    Cat Control
    Com as required by your computer
    Data bits 8
    Stop bits 2
    Handshake Hardware

    PTT CAT
    Mode Data/Pkt
    Split Rig

    de WA6PHR
     
  3. N2IEN

    N2IEN Ham Member QRZ Page

     
  4. N2IEN

    N2IEN Ham Member QRZ Page

    I'm having same issue with my FT991A. Currently on dxpedition in A5---can't get power output using WSJT-X. Transmit light illuminates, but no PO. Have read a lot of threads on this and tried pretty much every batch of suggested settings. One thing I do notice: Just before rig goes into transmit mode, "Data USB" changes to "USB" in the 991A's Mode window on the upper left of the main display. It then remains there until you go into the Mode menu and reset it to "Data USB." Settings issue of some sort I guess. Anyone have any insights?
     
  5. KD5LRQ

    KD5LRQ Ham Member QRZ Page

    I had it working for a while. Then the tuner went out. Sent it back to Yaesu for warranty repair. When it came back it worked just great. Then, suddenly, I would turn it on to work PSK31 with Fldigi and it wouldn't work. Same issue that N2IEN is having. It goes into TX mode, but no PO is registered. I'm not seeing the mode change, though. Checked the ALS and nothing there either. Checked all the radio settings and they were the same as previously used (I'd had a moment of clarity and wrote them down.). Went to Fldigi and checked all the settings there, same thing. All were the same as previously used. Pulled up the PC volume controls and looked at the volume output to the USB port. It was registering about 75% peaks. Then I did a full reset on the radio and reprogrammed it. Viola! It starting working. I assumed I had missed a setting somewhere and went about my business. I did notice that it required a large DT Gain to get max PO. After a while I had to turn it down due to ALS started kicking in. Worked great until the next time I wanted to use it a few days later. Did the same reset and it worked again. All this got me thinking that something is wrong with the radio. Now, this week, it's totally out. Rest of the radio works fine, but it won't work digital modes. I can manipulate radio settings via CAT, but it won't transmit the audio in digital mode. Oh, I almost forgot this...at one point the audio was coming out the radio speaker instead of being transmitted. The full reset took care of it. Happened to me twice along the way. I'm contacting tech support today. I'll give updates as I make progress.

    As a reference, the settings I'm using are as follows: All others are set at default.
    062 DATA MODE - OTHERS
    066 DATA LCUT FREQ - OFF
    068 DATA HCUT FREQ - OFF
    070 DATA IN SELECT - REAR
    071 DATA PTT SELECT - RTS
    072 DATA PORT SELECT - USB
     
  6. K3XD

    K3XD Premium Subscriber QRZ Page

    Please let me know if you resolved this issue. WK7A had his radio working great and then suddenly it stopped. We have reviewed multiple settings, etc. and cannot get it working again. Symptoms are the same: TX light goes on; however, no signal power out on the meter and TX does not time out as when it worked properly. We are using FT-991A, HRD, and WSJT-X.
     
  7. K6BRN

    K6BRN XML Subscriber QRZ Page

    Gentlemen:

    Are you sure that RF is not entering your computer and internal rig electronics? I had exactly these symptoms with an FT991 (required rig power cycling or a computer reboot to clear) and eliminated them by placing a coax feedline RF choke a few feet from the rig and by wrapping several turns of the USB cable through a ferrite core at both the radio and computer end.

    There may also be bigs in the WSJT-X version you are using. I suggest that you upgrade to the most current RELEASED version.

    Brian - K6BRN
     
  8. WD8ED

    WD8ED Ham Member QRZ Page

    Get the cat control working via USB/serial.

    Ensure audio drives are working and you know for a fact which TX and RX audio devices they are.

    Make sure that that the transmit Audio setting for the mode you are using is set to USB. That is how the playback audio device actually gets to the mic input. Without that setting being correct there will be no VOX operation (if set for VOX) or audio but good TX keying.

    Ed
     
  9. KC3JPP

    KC3JPP Premium Subscriber QRZ Page

    Well, I am having a similar issue with my FTDX3000. All of the software and Radio menu selections are correct and have been re-checked over and over. The issue in my case is that the radio is still trying to pull the audio from the mic even though the radio and software are clearly setup for the USB interface. I found this out accidentally when I coughed and saw the power meter jump when it was supposed to be transmitting in FT8.
    I assume that it is in the radio, however, I cant be sure that WSJT-X isn't doing something either.
     
  10. K6BRN

    K6BRN XML Subscriber QRZ Page

    Roy (KC3JPP):

    WSJT-X may very well be pulling the signal from the computers mic and not the radio. That is by far the most common problem. Disconnect the radio mic and clap your hands again. If output jumps, the computer mic is the source.

    You will need to go into the soundcard setup window on your computer (right click on the speaker icon if it is a PC) and set the radio sound device to have the USB port as it's input source AND output destination, them make similar changes in the WSJT-X Settings:Audio menu. Confirm the settings, reboot the computer and see if the problem is solved.

    When the computer mic is engaged, you will usually see a cluttered waterfall display that is directly driven by room noise. But WSJT-X may STILL decode some.

    This problem still creeps up when I move my laptop from QTH to QTH and radio to radio (two FTDX-3000s and two FT-991s) and this is how I solve it.

    Good luck!

    Brian - K6BRN
     

Share This Page