FT-920 CAT problems

Discussion in 'Computers, Hardware, and Operating Systems' started by KX4DV, Feb 2, 2018.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: Subscribe
ad: Left-3
ad: abrind-2
ad: L-MFJ
  1. KX4DV

    KX4DV Ham Member QRZ Page

    Yes, I've tried every combonation possible with even different cables and OS'. The FT-920 per Yaesu uses 4800, 8, N, 2.
  2. AG4F

    AG4F XML Subscriber QRZ Page

    If you're really intent on using the FT-920 for voice and data, you can do what I did - get a Rigblaster Advantage. It's not cheap at $200, however it interfaces both voice and data through the mic port. It will give you USB to PC connectivity (although I have no idea about Linux drivers), it has a built-in soundcard, adjustable xmit/rcv levels on front pots, etc. Best of all, it just works. You set it once and don't have to fiddle with it again. You also don't have to deal with the silly Yaesu required offset when using the rear data port.
  3. KX4DV

    KX4DV Ham Member QRZ Page

    That isn't the issue, nor does digital modes use the CAT interface. I already have a couple usb links for my rigs. The CAT is to control the function of the radio from the computer. (VFO, mode, bands, exc.)
  4. KE4BKL

    KE4BKL XML Subscriber QRZ Page

    Ok I have this very same issue. I purchased a Maxton RPC-6961-U-1.8M cable for my Yaesu FT-920. The day I received it, I hooked it up to my serial port in the rig straight to my laptop. Walaah it worked perfectly for a few months. Then all of a sudden one day I went to use my HRD software and now nothing is connecting anymore. I as well thought the cord was bad so I bought another one and the same problem persists. No CAT control anymore. I the purchased an FTDI A36 cable from GEARMO and this did not fix the issue either. Now the only problem I have is that as most know Windows 10 updates constantly so I am thinking there is a conflict somewhere between the laptop and the rig or a setting inside the rig has been changed. Either could be the case but yes it did work for a few months with HRD software flawlessly as it is supposed to. So now what? I do remote into my laptop from work to work DX through FT8 but now I can't change bands because the HRD software doesn't work. I have even a Yaesu software package designed for the FT-920 and I can not connect through that either. Since the other gentleman has used both Ubuntu and Windows platforms, this may not be a software issue but a setting in the rig that needs to be set to make the serial cable work but I have yet to find it in the service or tech manuals.
  5. KE4BKL

    KE4BKL XML Subscriber QRZ Page

    Well good and bad news Phillip. I believe I have found my problem and I bet it is yours as well. The serial port chip inside my radio is fried somehow. It is replaceable and not very expensive, as long as you have a steady hand with a soldering gun. I have tested this with multiple cables and a scope and found this out. This may or may not be your problem but from all of your descriptions your issue is the exact same as mine. Find someone that knows about this radio and send it to them to be fixed, hopefully locally for you as I have an Elmer that helps me with these issues as I can not hold a soldering gun steady to save my life. (I drink to much coffee) Good luck
  6. 4X1MK

    4X1MK Ham Member QRZ Page

    KE4BKL and the group de 4X1MK
    Did you change the serial port chip in your FT920? Did that fix the communication prob with the PC?
    I recently developed a similar problem... the radio and the computer stopped talking to each other.
    Please pass on the info as to where the chip is available.
    Thanks, Ron

Share This Page

ad: M2Ant-1