FT-857D and Turbo Tuner

Discussion in 'Mobile Radio Systems' started by N2ZD, Jan 16, 2020.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: OK1UUad-1
ad: Left-3
ad: Subscribe
ad: FBNews-1
ad: Left-2
  1. N2ZD

    N2ZD Ham Member QRZ Page

    Okay, here’s a stumper. I have a Yaesu FT-857D. The matching Turbo Tuner-2 and a Tarheel II screwdriver.

    Firstly, the coax is good, the antenna is properly grounded and the antenna works when electronically controlled by the rocker switch so that’s all good.

    The radio as per the instructions with the Turbotuner-2 were followed to a tee. Menus set to cat port, 4800 or 9600 baud and tuner as per the instructions.

    The 857’s “tune” button when depressed while in cw mode will beep twice but the TT-2 won’t respond to the command. I reset everything (master reset) then reset the appropriate menus properly, still doesn’t work.

    Now here’s the wacky thing, if I go into menu 85 and toggle from “off” to “tuner” the antenna will begin tuning and find a match. But only from within menu 85 like its initializing the cat port.

    The red light will come on on the radio and the TT-2 and it will tune the screwdriver and then transmit “k” in Morse to tell you it found a match. Which it does.

    The going out of the menu, if Use the tune button, you get the two beeps And no action from the TT-2. No red light on the rig or TT-2

    So the antenna is electrically and physically good.

    Apparently from the menu it initializes the TT-2 while in that number 85 menu choice.

    All grounds are good, the antenna works with the manual switch, tried the reset, tried the menu settings, tried the dip switches on the TT-2, tried shutting the remote mic choice in the menu etc etc. nothing allows tuning from the front of the rig.

    Anyone ever come across this?

    Thanks Richy N2ZD
     

Share This Page