FT-101E - ALC meter

Discussion in '"Boat Anchor" & Classic Equipment' started by VK2CAO, Oct 10, 2020.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: abrind-2
ad: L-MFJ
ad: Left-2
ad: Left-3
  1. VK2CAO

    VK2CAO XML Subscriber QRZ Page

    ALC circuit went zzzit and needle stayed left. Replaced sm caps, resistors and diodes but now needle stays locked
    right hand side.
    Rig is OK for AM and CW but SSB is no good.
    How can I fix?
    Help is much appreciated.
    PSU is refurbished 230VAC grounded and ALC is the only problem.
    RF PO about 120W bit lower at 10MHz.
    I have spare parts rig with ALC that was working OK.

    73 and thanks VK2CAO Noel
     
  2. W1NB

    W1NB XML Subscriber QRZ Page

    Attached are the pages from the service manual that describe both the ALC function and troubleshooting. 98653740-EB66-43FA-B4E8-E13759F71460.png 6311CDC7-9EB8-4FA8-BC0A-6C550324FF95.png F4667C83-0BE4-43CE-9BB2-D7E584305E8F.png
     
  3. W1NB

    W1NB XML Subscriber QRZ Page

    I would first check the Idling current/bias to see if there’s any issue there.
     
  4. G3YRO

    G3YRO Ham Member QRZ Page

    The ALC is designed to only work on SSB, as it's to prevent distortion from over-driving, and you can't overdrive on CW !

    Does the rig work OK on SSB? i.e. do you get full power output? (apart from not getting any ALC indication)

    The one essential maintenance on these rigs is cleaning the Contacts on the Main Relay every 4/5 years . . . if the contacts become dirty, you can get all kinds of faults (including getting no ALC reading!)

    Other than that, if the rig works fine on SSB but you're getting no ALC reading, I would check the 2 Germanium Diodes (D2 & D3) that provide the ALC voltage.

    Roger G3YRO
     
    Last edited: Oct 11, 2020

Share This Page