ad: SDRKits-1

FLrig and FLDigi won't talk. What Am I Missing?

Discussion in 'Amateur Radio Software' started by NQ4T, Apr 20, 2020.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: Left-3
ad: Left-2
ad: abrind-2
  1. NQ4T

    NQ4T Ham Member QRZ Page

    Hi all,

    I recently put my IC-725 back on the bench, got it working again, and hooked it up back in the shack. I've been in the process of getting all the software set back up on this computer, which has changed since I'm now using C-IV with the 725. I've hit a wall trying to figure out why I'm not getting fldigi and flrig working together when they're supposed to. My setup is probably a lot more confusing than I'm making it, but I'll explain it anyway.

    The OS is Windows 10; I've tried this with both release versions of flrig and fldigi, as well as developer builds. The 725 isn't on flrig's list, which isn't a huge deal as the basic command functions are the same; but since I'd put my radio in to "731 mode" during all my Arduino/RPi experiments, flrig is configured for IC-735, which is on the list. (The only differences are the 725 uses 5-byte BCD data and has the split command). The C-IV interface is the same as I've used for both my Arduino/RPi stuff; in fact I pulled the microcontroller out of the Uno board and just use it's USB-to-serial data lines (provided by another microcontroller) to drive the interface. Audio interfacing and PTT are provided by my old self-built interface using a CH340 dongle.

    Flrig on it's own works just fine; I can boot it up and it'll sync with the radio no issue. WJST-X has had zero issues working this setup for the last several days. I can even tell fldigi to use hamlib and everything works as expected.

    But if I tell fldigi to use flrig and boot flrig up after Fldigi; that's where things go awry. Sometimes the titlebar of Fldigi will indicate it's connected to a 735; but it can't key the rig and doesn't change frequencies. Often times, it appears for a few seconds before it disappears. Booting flrig first and then fldigi usually just causes things to lock up that I have to reset the serial adapters.

    I've tried both release versions of fldigi + flrig as well as development versions. I've made sure the versions I'm running "match" (release versions of both or dev versions of both). I even went ahead and rebooted the PC to make sure there wasn't something weird going on there.

    Has anyone else had this issue? I mean people push flrig as being "the preferred" way of controlling your rig with fldigi but the two just seem to refuse to communicate.
     

Share This Page

ad: chuckmartin