Fldigi with RigBlaster - No real-keyed CW in Linux

Discussion in 'Amateur Radio Software' started by KB5MPJ, Sep 25, 2020.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: L-MFJ
ad: abrind-2
ad: Left-2
ad: Left-3
  1. KB5MPJ

    KB5MPJ Ham Member QRZ Page

    I am able to use my Fldigi with my RigBlaster Advantage to perform real-keyed CW on my Kenwood TS-120s in Windows, but not on Linux even though I use the same settings in Fldigi on Linux. The settings that work in Windows are:

    Connect CW/FSK jack of RigBlaster to CW jack of radio.
    Connect microphone cable between RigBlaster and radio.
    Set TX switch of RigBlaster to VOX. Do not enable VOX on the radio.
    In Fldigi, go to Rig Control | Hardware PTT
    Check only "Use separate port PTT" and "Use RTS."
    Choose the correct device (Happens to be COM4) in WIndows

    In Windows, Fldigi will automatically PTT the radio and key CW that I enter. The FSK light flashes with each dit/dah. Fldigi releases PTT when finished.

    In Linux, I get no PTT or CW keying activity with the same settings I used in Windows. I checked to make sure I selected the correct device in Rig Control settings Linux and even tried all the other devices to be sure.

    Software versions:
    Windows: 8.1
    Linux: OpenSUSE 15.2
    Fldigi: 4.1.14

    Any suggestions?
     
  2. KB5MPJ

    KB5MPJ Ham Member QRZ Page

    I should add that I have all the other digital modes working with FLDIGI in Linux. Just no real-keyed CW. The RigBlaster settings say to have the Rigblaster TX switch set to "COM" for the other digital modes, but "VOX" for CW, so that is what I've done.
     
  3. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    not sure about open suse but on linux mint I had to list the serial ports and find the usbtoserial board I was using to see what com port linux had it on. Turned out that usb was on port 33, dont know why but way different than win7.
    I also had to get permissions for it on the dialout group.

    theres lots of references on google or you might try groupio https://groups.io/g/LinuxHams

    https://www.cyberciti.biz/faq/find-out-linux-serial-ports-with-setserial/

    I would have to check settings with my son out in BC, thats where the interface ended up but it will do cw keying and ptt
    It was tried on my FT757GII with QSSTV, fldigi, wsjt-x and cw type before I shipped it out there
    Its being used mainly on FT8 on an IC751A

    hope this gives some ideas
     
    KA9JLM likes this.
  4. KA9JLM

    KA9JLM Ham Member QRZ Page

    Did you tell Linux to give Rights to the software and port that you are using ?

    Just a long shot, Why it may not be working.
     
  5. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    you're definately going to have to find out what tty port the rigblaster usb is on and I believe you'll have to switch "off" vox for cw and make sure the switched line for cw goes to the key input on your rig (check for voltage compatability first). If you have the rig on vox and are sending cw as tones into your rig then the rig may have to be on ssb rather than cw and using vox.
    Keyed cw will need to have the rig setup on cw and your rigblaster should switch the key input on the rig like a regular morse key.
    At least thats what I would think but the manual should say something about PTT and/or keying input or perhaps rigblasters help line

    I started out doing cw that way but decided that having the rig do keyed cw would be best for filters, pure cw, etc. Vox worked on digital modes with computer audio feeding my rigs but I decided to have the usb board do PTT and keying from rts & dtr

    As KA9JM suggests check the rights in linux

    I think I had RTS on the little usb2serial board for key input and DTR hooked up for PTT, but either could be configured for either way.
    any way this is the little board from amazon [​IMG]
    and I fed the rts & dtr outputs through opto isolators
     
  6. KB5MPJ

    KB5MPJ Ham Member QRZ Page

    I got it working, and I'm not sure exactly how. I made sure my user is in the dialout group (It already was). I logged in as root, and it still didn't work. Booted into Windows for a while, then back into Linux, and it's working. On Modem | CW | DTR-RTS Keying, I have the CW keyline set to DTR, and "Use Separate Keying Serial Port" is set to "...Rigblaster_Advantage...port0." On Rig Control | Hardware PTT, it is set to "Use separate serial port PTT," Device is "...Rigblaster_Advantage...port0," and only "Use RTS" is checked. The toggle switch on the RigBlaster is set to VOX.
     
    KA9JLM likes this.
  7. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    great ! enjoy
     

Share This Page