FLDIGI not working On hardware PTT

Discussion in 'Computers, Hardware, and Operating Systems' started by KC5SHE, May 30, 2017.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: l-BCInc
ad: Left-3
ad: Left-2
  1. KC5SHE

    KC5SHE Ham Member QRZ Page

    I am having issue getting FLDIGI to key my radio using a com port RTY pin. My setup is a Yaesu SCU-17 connected to my Yaesu FT-897D. At this time I am not doing rig control and all I am using is the data port connection. I know the drivers and configuration are correct because I can make it work fine using Airlink Express , Commander, and I can also manually key the radio using a serial port utility. I am running Windows 10 and FLDIGI 4.3.6. I have also tried to back level FLDIGI to 4.0.4... In the past I have had other issues with FLDIGI and by going to older versions it corrected some issues but I lost new features. FLDIGI Is the most robust Digital mode program out there and it would be great if it worked on something as simple as keying the radio with a com port. Has anyone else seen this issue and do we know if the FLDIGI community is working on a fix?

    Thank you for any assistance you can provide.
    73.. KC5SHE
     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    I feal really dumb now, But can learn quick. What is a com port RTY pin ?

    What OS are you using ?

    Good Luck, You can make it work. :)
     
  3. KC5SHE

    KC5SHE Ham Member QRZ Page

    Sorry, typo. RTS pin.
     
  4. KC5SHE

    KC5SHE Ham Member QRZ Page

    Also I am using Windows 10. I am considering loading Linux on an older laptop to see if the Linux flavor of Fldigi will work.
     
  5. KD3WB

    KD3WB Ham Member QRZ Page

    Start Fldigi, click "Configure", "Rig Control", click the "Hardware PTT" tab, check the boxes marked "Use separate serial port PTT" and "Use RTS". Then make sure the correct COM port is listed and click "Initialize". If you are not sure which COM port to use, press the Windows and "R" keys simultaneously, type "devmgmt.msc" into the "Open" box, click "OK". then double-click "Ports".

    Ben
     
  6. KC5SHE

    KC5SHE Ham Member QRZ Page

    Thank you for your response Ben.
    I have gone thru that setup process many times and gone thru RTS, RTS +V, DTR, DTR +V. I have verified the com port number several different ways including directly accessing it with a serial port utility that will allow me to manually trigger the PTT. I have two other PSK31 programs successfully using the com port to trigger PTT.

    I have been using Fldigi for several years and have had great success with other interfacing methods that use VOX to trigger the radio PTT. Unfortunately the VOX method only works on my FT-897D in the HF bands. The moment the radio is used on 2 meter or 70 cm the VOX thru the data port is disabled and you must trigger the PTT by using the PTT line in the data port. This disabling of VOX on the data port what a deliberate design decision by Yeasu.

    I am truly hoping that I missed some configuration setting in Fldigi but I don't think that is the case. I have configured older versions of Fldigi on Windows 7 using different hardware to do com port PTT and it worked fine and that is why I am fining this issue to be very frustrating.

    73... Scott....
     
  7. KA9JLM

    KA9JLM Ham Member QRZ Page

    Sounds like maybe a unsigned driver issue. Win 10 claims for security. :rolleyes:

    To keep from jumping thru too many hoops,

    Select "disable driver signature enforcement"



    Good Luck.
     
  8. G4NCE

    G4NCE Ham Member QRZ Page

    Had the same issue myself and allowing unsigned drivers sorted the hardware PTT in Fldigi for me. Thanks for posting Donald.
    73
    Martin
    G4NCE
     

Share This Page

ad: wmr-1