ad: elecraft

FlDigi not following radio

Discussion in 'Rig Control, Propagation, Cluster, & Other Softwar' started by AC2MM, Oct 5, 2018.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: l-assoc
ad: Left-3
ad: Subscribe
ad: L-MFJ
  1. AC2MM

    AC2MM Premium Subscriber QRZ Page

    Last night I set up Fldigi, got it working great without FlRig, everything was perfect.
    It was even following the radio like I expected (Kenwood TS-590S).
    I shut it down, clicked on "Save changes", and this morning I started it back up, and it's working fine again only it won't follow the radio now.

    What could I possibly have done if I just "saved the Changes"?
    Everything in my system is 9600 baud due to the SteppIR antenna.

    Thanks,
    Robert
     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    Maybe the port number changed.
     
  3. AC2MM

    AC2MM Premium Subscriber QRZ Page

    I tried that, no luck.
    But I'm guessing it's something on the RigCat tab.
    Just a guess.
    Do other guys have it follow the radio w/o using FlRig?
     
  4. KD3WB

    KD3WB Ham Member QRZ Page

    Fldigi will do limited rig control without Flrig, including frequency changes. Be sure that the box at the top of the RigCat page is checked and correct COM port number is selected. Then press "Initialize".

    Ben
     
  5. AC2MM

    AC2MM Premium Subscriber QRZ Page

    It's kinda weird. It worked by accident before, but on a restart it doesn't. Figures...
    I select different Com ports, "Use RigCat", different check boxes, every time hitting "Initialize" before I twist the radio dial, all with the same result.
    It works fine, TX/RX, everything except following the radio.
    I guess I'll have to subscribe to the FlDigi forum. I even turned off HRD in case it had exclusive use of the Com port, no difference.
    I appreciate you trying.

    And I can't figure out why QRZ is not sending me emails when someone answers. I've checked the email address listed, and even sent a test email , all works. Oh well...

    Thanks.
     
  6. KD3WB

    KD3WB Ham Member QRZ Page

    If you are using Windows, press the Windows and "R" keys simultaneously, type "devmgmt.msc" into the "Open" box and click "OK". When Device Manager starts, expand "Ports" and you should be able to see the COM port number being used. Also, to get emails, I think you have to click "Watch thread" at the top.

    Ben
     
  7. AC2MM

    AC2MM Premium Subscriber QRZ Page

    Wow, I have three:
    Communications Port (COM1)
    Intel Active Management Technology - SOL (COM3)
    Silicon Labs CP210X USB to UART Bridge (COM4)

    HRD uses the ACC2 Port on the back of the Kenwood to access the SignaLink sound card for TX/RX. The output of the SignaLink goes to (I believe) COM4 of the PC.
    HRD also uses the Kenwood USB port direct to the computer for something, I can't remember what.
    The SteppIR SDA 100 Controller uses the Kenwood 9 pin Serial port for it's use, and the antenna follows the radio perfectly. (and also HRD)
    So I can change frequencies using HRD, or the radio itself, and the SteppIR will follow along and retune.

    FWIW, when using WSJT-X, any switch to a different mode/frequency immediately produces a change in the SteppIR, HRD and the Radio itself, so it's configured perfectly like FlgDigi should be. While the logical question should be "What port does WSJT-X use", it doesn't say. It lists the Rig as Ham Radio Deluxe, and the Mode as USB. So I'm assuming that it's also using the USB port on the back of the Kenwood, but it's simply a guess.

    Right now, FlDigo works perfectly for all operations of TX/RX, and it's listed as COM4 in Configuration.

    Thank you for your help, BTW, I do realize what a pain in the butt software troubleshooting can be.
     
  8. KD3WB

    KD3WB Ham Member QRZ Page

    If you are using RigCat, you might try refreshing the TS-590S.xml file. Don't forget to click "Initialize".

    Ben
     
  9. AC2MM

    AC2MM Premium Subscriber QRZ Page

    I forgot about this forum.
    You guys were nice enough to try and help me out, so I wanted to return the favor in kind.
    I did temporarily join the Winfldigi forum, but I've never had much success there with configurations. People try of course, but everybody's hardware/software situation is so different from each other, it makes it virtually impossible to give the exact direction to make it all work.

    In the end, I finally found the combination that worked. And then I got a "nastygram" from the lead programmer that said basically "Among the options available to get it to work, I picked the least one advisable" if you can believe that. Oh well...

    Anyhow, in the interest of letting you know my success and how I obtained it, I'll copy and paste both my reply and the appropriate photo's. The context of this discussion was "Do whatever you did in WSJT-X" basically, which was a sound idea, but didn't help much.

    Here goes:
    START QUOTE:

    Thank you for your help, first and foremost.

    I got it. (drumroll)

    First, though, there is no dropdown like you describe in WSJT-X, latest version. Here is mine:

    upload_2018-10-15_21-49-11.png

    HRD takes control of COM4 when it's running. That's why WSJT-X is set for COM4 **but** is also set for Ham Radio Deluxe. They do work together with COM4.

    Fldigi does not, however.

    The next two pictures are what fixed the problem:

    upload_2018-10-15_21-49-11.png


    upload_2018-10-15_21-49-11.png



    Two things were discovered. HamLib and HRD are separate programs obviously, but must operate much the same way.
    As you can see, the two important keys to the solution is that "Hamlib" was selected, but (second screen) the CAT control is via Fldigi, *not* Hamlib.
    Also, now the entire frequency is displayed correctly as well.

    The bottom line here is that HRD and Fldigi cannot work together, even though the DM-780 is not running. They both want COM4, and while WSJT-X works with HRD using COM4, Fldigi will not do the same. If Fldigi is running, HRD will not start. The reverse is true also.
    It's too bad, because it would be nice, like with WSJT-X, to have my HRD Logbook operating while Fldigi is running so I can type in the QSO info.

    If some Fldigi / HRD user has found a way for both to operate together, I would be very happy to know how he did it. They're competitors obviously, so maybe that's by intent, who knows. Eventually, Fldigi will go Commercial IMO. (Comment from me....this last sentence put a large burr under the saddle of the head programmer )

    The other remaining problem was that Fldigi would not store the correct frequency in the Logbook. I will test this later today sometime, perhaps its related and that is now working correctly also.

    If you guys have any more questions, I will be happy to accommodate you.
    Thank you for your help.

    END QUOTE

    I subscribe to the KISS principle. If it works, don't fix it.
    It's working great, correct frequency reports, et all, Brutus.

    Thanks again for trying,
    Robert AC2MM
     
    KA9JLM likes this.

Share This Page