fldigi/flrig w/ICOM IC-756 Pro via Signal Link USB (to a MacBook Pro 4,1 running El Cap)

Discussion in 'OS: Mac OS' started by KD7OWY, Nov 9, 2019.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-3
ad: Subscribe
ad: Left-2
ad: MessiPaoloni-1
  1. KD7OWY

    KD7OWY Ham Member QRZ Page

    Hello everyone - I'm totally new to digital modes and I'm having some trouble setting up my software to properly communicate with my rig.

    I'm using:

    * MacBook Pro 4,1 running El Capitan (10.11.6)
    * fldigi 4.1.08
    * flrig 1.3.48
    * ICOM IC-756 Pro
    * Signal Link USB

    The Signal Link is properly configured and PTT activates with the fldigi output tx. The waterfall/scope follow the modulations of the frequencies received by the rig. So I know the interface hardware is working.

    fldigi and flrig are speaking to each other properly. When I change the frequency in one, it changes in the other. So I know the problem isn't within the software communications.

    My trouble is with flrig. The program doesn't connect to the transceiver.

    My config settings are (see attached):
    * Rig - IC-756PRO
    * Ser Port - NONE
    * Baud - 19200
    * Stop bit - 1
    * Echo - check
    * PTT via CAT
    * Retries - 1
    * Retry interval - 2
    * Commands - 0
    * Poll interval - 200
    * Byte interval - 0
    * CI-V address - 0x5c

    and the settings on the ICOM are:
    * CI-V Baud - 19200
    * CI-V address - Ch5

    I believe the issue is with my selection of serial port. The interface is plugged into one of two USB ports on the left side of the laptop. I have tried all of the options in the drop down menu for "Ser Port" and I get the same error message for all of them when I press "init":

    "Transceiver not responding!

    Check serial (COM) port connection
    Open menu Config/Setup/Transceiver
    Press 'Ser Port' button, reselect port
    Press 'Init' button"

    None of the options in the dropdown menu look quite right and I don't know how to verify the serial port identifier for the particular USB port I'm using to enter it manually.

    Any help is appreciated!

    73 Tom
    KD7OWY
     

    Attached Files:

  2. AF9US

    AF9US Premium Subscriber QRZ Page

    Tom, KD7OWY:

    It appears that you have not installed the drivers for the Icom 756PRO. If you have installed the drivers you would see something similar to this in the drop down list for Serial Port in flrig:

    /dev/cu.SLAB_USBtoUART
    (This is how the Serial Port driver shows-up in the drop-down list for my Icom IC-9100.)
    The driver and installation package should be available on the Icom web site for the IC-756 PRO, and most likely is available on Silicon Labs web site.

    For the IC-9100 and, I believe, for all Icom radios you must disconnect the radio from the computer USB port before installing the drivers from Icom or Silicon Labs. Once the drivers are installed, connect the radio to the computer USB port, start-up fldigi and flrig, then select the correct driver (just installed) in the drop-down list for the Serial Port parameter in flrig.

    If you are experienced in using Unix commands in the Terminal window, you will find all the drivers installed on your MacBook Pro 4 in the /dev directory. Use the unix command: ls, to list all the driver files in the /dev directory.

    Good luck,
    Bernie, AF9US
     
  3. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Bernie,

    The 756Pro doesn't have an USB connection on the back, and there are no drivers to install. The rig is too old for the (now-standard) use of USB ports on the back.
     
  4. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    The one thing you did not mention is how you are doing CAT to the 756Pro. The SignalInk USB is a sound card only which provides audio input/output and triggers the PTT on the rig. It does not provide the connections for CAT control, thus FLRIG has no path to control the rig. You need to get a CAT cable to connect your MacBook to the rig before you tackle rig control.

    Since the 756Pro doesn't include a RS-232 connection on the back, you'll need to use the CI-V jack to provide the control and you'll need to obtain a CT-17 type converter. One that I've seen used in the past for Macs is this one from Black Cat Systems, a long-time Mac supporter: https://www.blackcatsystems.com/usbciv/usb_icom_ci-v_interface.html. You shouldn't need to install any drivers as the FTDI drivers are included in El Capitan, if I remember correctly, but if you do then they're readily available at the FTDI website (https://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_4_2.dmg)


    I hope this helps, Tom.

    73
     
  5. AF9US

    AF9US Premium Subscriber QRZ Page

    I appreciate the info, K3DCW.

    Thank you,
    Bernie, AF9US
     
  6. KD7OWY

    KD7OWY Ham Member QRZ Page

    Thanks for all the assistance!

    I didn't really think this through. Thanks for setting me on the right path. I obtained the recommended interface from BlackCat. It came with a CD with the drivers. I installed the software and linked up the rig and everything seems to be working perfectly so far. This is really cool and I'm very excited to start playing around with this setup.

    Thanks again everyone!
     
    K3DCW likes this.
  7. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Glad to hear it. Enjoy!
     

Share This Page