FLdigi, FLrig, MacOs X Catalina, Yaesu FT-450D, SignaLink USB

Discussion in 'Mac Ham Radio on macOS & iOS' started by KI5OOS, Sep 3, 2021.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Left-2
ad: Left-3
ad: L-MFJ
ad: HRDLLC-2
ad: L-Geochron
ad: MessiPaoloni-1
  1. KI5OOS

    KI5OOS Ham Member QRZ Page

    I am stumped.

    Cannot get FLrig to recognize my radio via the SignaLink interface.
    Cords and connections good
    SignaLink setup verified by using TigerTronics jumper chip for my radio
    Yaesu FT-450D manual consulted and directions followed for digital modes

    The error message is: No com port (from FLrig)

    I've gone through all the steps to set this configuration up properly.

    Any help would be so MUCH appreciated.

    Thank you, in advance!

    Tim
     
    NC0Q likes this.
  2. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    If you search the forum, you'll see a whole lot of this kind of post and the solution is always the same.

    The SignaLink USB interface is a sound card only and contains no provisions for CAT control. You need another USB-Serial (I always recommend the TrippLite USA-19HS) to connect your computer to the rig so that Flrig can control the radio.
     
    NC0Q and KI5OOS like this.
  3. KI5OOS

    KI5OOS Ham Member QRZ Page

    I am so grateful for your reply. Answering the same question over and over is tedious. I'm so new that I wasn't sure about my question, let alone how to ask it. Thank you for your help.
     
    K3DCW and NC0Q like this.
  4. KI5OOS

    KI5OOS Ham Member QRZ Page

    I have ordered the exact cable you recommend. Thank you!

    New problem, and I KNOW it's a sound card/SignaLink issue. I have a MacBook Pro with a Windows 10 installation running via Bootcamp. The Windows version of FLDigi runs perfectly. On the Mac/Apple side, there is no audio getting into FLDigi. Over and over I have run the configuration for FLDigi and quadruple-checked that USB Audio Codec is selected for transmit/receive. I've made sure OS X Catalina is using the built-in audio for the operating system sounds. Transmit, in FLDigi, is working fine. The software keys the radio - no issue. In the configuration dialog for SignaLink within FLDigi the level meter indicates (by zero activity) there is no audio coming into the software. Again, I am stumped.

    Any ideas for me to try?

    Tim
     
  5. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Another common issue, so don't feel bad. Go to:
    System Preferences
    Security and Privacy pane
    Under the "Privacy" tab, look for "Microphone" on the left-hand side.
    Select "microphone" and then allow Fldigi to access it.

    Even though the USB Audio CODEC/SignaLink is obviously not a "microphone" in the true sense of the word, that's the way that macOS treats it. Once you allow Fldigi to access the microphone, you should be good to go.
     
  6. KI5OOS

    KI5OOS Ham Member QRZ Page

    Wow. Thank you so very much.

    Tim
     

Share This Page