FLDIGI and FLRIG won't work with Xubuntu and IC7300

Discussion in 'Amateur Radio Software' started by KE0EYJ, Jun 30, 2018.

ad: L-HROutlet
ad: l-rl
ad: l-BCInc
ad: L-MFJ
ad: Subscribe
ad: MessiPaoloni-1
ad: l-assoc
  1. KE0EYJ

    KE0EYJ Ham Member QRZ Page

    Pulling my hair out. Nothing online has helped.

    I am NOT a Linux expert.

    I have installed Linux on this machine a few years ago, and removed it. I have since reinstalled. I am trying to get FLDIGI to run my Icom 7300. I have it working perfectly through Windows. Linux, however, absolutely will not talk to the radio.

    I have done the "dialout" thing, but I am totally confused about what that is. First time I tried to do it, I was told that it had already been added -- but I don't remember ever doing that, unless I added it under a different version of Linux 2 years ago? I stupidly chose a basic name for my Linux username install, and I wonder if someone else somewhere had added that to dialup, so that's why it does not work for me?

    I just get 0 rig control at all. Sound card seems to work fine on Rx into FLDIGI, otherwise. It won't transmit. The numbers on the rig and FLDIGI differ.

    Completely clueless here. I have tried the rig description file for the 7300. I have tried Rigcat and have it set up per online instructions. I have tried Hamlib, and that does nothing.

    HELP.
     
  2. VE3CGA

    VE3CGA Ham Member QRZ Page

    I'm no linux expert either, but on these USB rigs (I have a 9100) I think there is some sort of virtual port magic that has to be done
    I got fldigi to work on the spkr aqnd mic audio jacks by installing a rather large line by line edit using terminal.
    It worked great on linux mint 17.3 with my ic751a but there is something needed to reroute the audio ports to the usb sound port on the 9100
    and thats where I have left things. there is different and numerous explainations on the linux forums for ham radio

    the best thing it to search for fldigi and linux mint for installing fldigi

    for getting the sound ports to work I would try google groups ic-9100@groups.io and I believe there are 2 for the 7300 ic-7300 and icom7300 both at group.io
    or linuxhams@group.io

    heres a link I found for getting the usb ports on the 9100 it might shed some light on the 7300
    http://kb4lhp.blogspot.com/2015/03/setting-up-icom-ic-9100-in-ubuntu-1404.html

    if you find something that works, please let me know

    73's Bob VE3CGA
     
  3. VE3CGA

    VE3CGA Ham Member QRZ Page

    oh and I forgot, I thought of using the wine emulator in linux, but I believe it requires even more tinkering
     
  4. KF5RRF

    KF5RRF Premium Subscriber QRZ Page

    @KE0EYJ

    You're on the right track. Your user has to be in the dialout group which you've already done. In fldigi, you should be able to use rigcat as you already have the XML file from what I've read. You didn't mention anything about setting up the serial port. Typically, if you only have the one USB serial interface, the device name is going to be ttyUSB0. When specifying the port, use the full path - /dev/ttyUSB0. Everything is case-sensitive.

    While I don't have an IC-7300 to test with, I do have this working with my IC-7000 and IC-7200 under Ubuntu Linux using hamlib and rigcat. I've taken a screenshot of the settings for fldigi using rigcat on my system for your review. Maybe this will help.


    Screenshot_20180630_172633.png
     
    KE0EYJ likes this.
  5. KE0EYJ

    KE0EYJ Ham Member QRZ Page

    Will try it later. Have tried every port. The ones you mentioned, included. No good.

    Is it possible that someone else had the same screen login name, and set up the dialup with that, so mine says it is done, but it doesn't actually make the connection for me?
     
  6. KF5RRF

    KF5RRF Premium Subscriber QRZ Page

    With the rig plugged into the Linux PC, have you verified that /dev/ttyUSB0 exists in the /dev directory? If not, you'll have to find out why. This could be anything from a setting on the IC-7300 to a bad USB port. But, that device has to present in order for it to work. And, it should all be automatic.
     
  7. KE0EYJ

    KE0EYJ Ham Member QRZ Page

    I am seeing a port called: /dev/serial/by-id/usb-Silicon_Labs_CP2102_USB_to_UART_Bridge_Controller_IC-7300_01002946-if00-port0. I have tried it, and attempted to initiailize it. I have the checkbox at the top checked. Nothing.

    I am also seeing: /dev/ttyS0 , followed by choices for the same thing ending in ttyS1, and so forth. The last choice is the one I listed above.

    It's receiving from my computer, but will not transmit or register the correct frequency, or change the frequency.
     
  8. KE0EYJ

    KE0EYJ Ham Member QRZ Page

    I have also seen .pdf files saying something about old versions of fldigi not working with the USB port, but that new versions fixed it. It said that you had to completely remove the old version, before installing the new, or it would not work. I removed it, and reinstalled from online, but it seemed to remember my previous settings. This leads me to believe that it was not "completely" unistalled, somehow? I used the uninstall button from the Software store to remove the first version I'd had installed. I am at a loss as to any other way to uninstall it?

    My first version came from the Software center of Xubuntu. The second version was from online, and appeared to be the newest (actually, I think both were the same version, but not sure).
     
  9. KF5RRF

    KF5RRF Premium Subscriber QRZ Page

    Sorry to take so long to reply. It's hard for me to get on QRZ during the week due to work and... well... work. ;)

    There's an .fldigi directory that contains saved settings in your home directory. If you don't care about what's in it, you can delete it:

    Code:
    rm -rf .fldigi
    or, better yet, just rename it
    Code:
    mv .fldigi .fldigi.old
    .

    The /dev/ttyS0 through /dev/ttyS3 devices are for your standard COM ports. So, if you're familiar with DOS/Windows serial port names, /dev/ttyS0 = COM1:. It's highly doubtful that the serial device is even set to ttyS0.

    You should be able to use that long name. If it's too long for some reason, you can look at that device node by doing a list of /dev/serial/by-id/ to see where it goes - it's just a symbolic link (at least on my system; should be on yours, too). Once you find the real name, you could try using that. Unless the IC-7300 is doing things really differently, it should work for the most part.

    The last thing I would check is to make sure what BPS rate the radio is set for or defaults to. If it's something other than 19200 like the screenshot, set it to that value in fldigi.
     
  10. K3NAW

    K3NAW Ham Member QRZ Page

    Are you sure you are a member of the dialout group? After reading your initial post, I am not sure.
    Bring up a terminal and type groups at the prompt then hit enter. Check to see if dialout appears in the output. If not, enter it again.

    as an example say your username is joe you would at the prompt type: sudo adduser joe dialout
    you will have to log out and log back in (and perhaps reboot) for the change to apply.
    Here is a linux ham group where you can find more info if needed.
    https://groups.io/g/linuxham. This group was created for the Fldigi group of programs and the developer is a frequent contributor.

    73
     
    KF5RRF likes this.

Share This Page